<!DOCTYPE html>
<html lang="en">
    <head>
        
    <meta charset="utf-8">

    
    


        
    
        
    <script>
    var gomez={
    gs: new Date().getTime(),
    acctId:"D3FD89",
    grpId:"Escenic",
    grpId1:"FTW",
    grpId2:window.location.hostname,
    grpId3:"unknown",
    pgId:"story-detail",
    wrate:1
};
</script>




    
        <meta name="msapplication-TileColor" content="#FFFFFF"/>
    

    
        <meta name="msapplication-TileImage" content="https://www.star-telegram.com/wps/source/images/star-telegram/windowsmetro-144.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-144-precomposed.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-114-precomposed.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-72-precomposed.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-57-precomposed.png"/>
    

    
        <link rel="shortcut icon" href="https://www.star-telegram.com/wps/source/images/star-telegram/favicon.png"/>
    

    
        <meta name="twitter:card" content="summary_large_image"/>
    

    
        <meta name="twitter:site" content="startelegram"/>
    

    
        <meta name="twitter:title" content="Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge"/>
    

    
        <meta property="og:site_name" content="star-telegram"/>
    

    
        <meta property="og:type" content="article"/>
    

    
        <meta property="og:title" content="Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge"/>
    

    
        <meta property="og:url" content="https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html"/>
    

    
        <meta property="og:description" content="Rougned Odor collects an inside-the-park-homer as part of his 5-for-5 game that lifted his average to .270. That’s a far cry from where he was two months ago and last season, but the Texas Rangers don’t want their surging second baseman to forget his baseball demons."/>
    

    
        <meta name="twitter:description" content="Rougned Odor collects an inside-the-park-homer as part of his 5-for-5 game that lifted his average to .270. That’s a far cry from where he was two months ago and last season, but the Texas Rangers don’t want their surging second baseman to forget his baseball demons."/>
    

    
        <meta property="og:image" content="https://www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_1140/0728%20Rangers%20Reaction%20art%201.JPG"/>
    

    
        <meta name="twitter:image" content="https://www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_1140/0728%20Rangers%20Reaction%20art%201.JPG"/>
    

    
        <meta property="fb:app_id" content="155812681283151"/>
    

    

    
        <meta name="title" content="Texas Rangers: Odor sticking to plan after awful 2017 | Fort Worth Star-Telegram"/>
    

    
        <meta name="allow-comments" content="true"/>
    

    
        <meta name="description" content="Rougned Odor collects an inside-the-park-homer as part of his 5-for-5 game that lifted his average to .270. That’s a far cry from where he was two months ago and last season, but the Texas Rangers don’t want their surging second baseman to forget his baseball demons."/>
    

    
        <meta name="keywords" content="Texas, Rangers, Houston, Astros, mlb, baseball, Ariel Jurado, Rougned Odor, Delino DeShields, Cole Hamels, Eddie Butler"/>
    

    
        <meta name="news_keywords" content="Texas, Rangers, Houston, Astros, mlb, baseball, Ariel Jurado, Rougned Odor, Delino DeShields, Cole Hamels, Eddie Butler"/>
    

    
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
    

    
        <meta name="googlebot" content="noodp, noarchive"/>
    

    
        <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
    

    
        <link rel="canonical" href="https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html"/>
    

    
        <meta name="original-source" content="https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html"/>
    

    
        <meta name="google-site-verification" content="zLQTVtfwr_FaFe6A7f-Yxjz2dhOn4VTFy87suqUWDLo"/>
    






<meta name="title" content="Texas Rangers: Odor sticking to plan after awful 2017 | Fort Worth Star-Telegram">
<meta name="og:title" content="Texas Rangers: Odor sticking to plan after awful 2017 | Fort Worth Star-Telegram">
<title>Texas Rangers: Odor sticking to plan after awful 2017 | Fort Worth Star-Telegram</title>

<link rel="amphtml" href="http://amp.star-telegram.com/sports/mlb/texas-rangers/article215705830.html">

<meta name="msapplication-TileImage" content="/wps/build/images/star-telegram/windowsmetro-144.png"/>




        <meta property="fb:pages" content="17636558529" />
        <meta property="fb:pages" content="111861725523499" />
        <meta property="fb:pages" content="119745086652" />
        <meta property="fb:pages" content="1104538766257425" />
        <meta property="fb:pages" content="154492971266054" />
        <meta property="fb:pages" content="150882488273569" />
        <meta property="fb:pages" content="166735760040344" />
        <meta property="fb:pages" content="104439729607265" />
        <meta property="fb:pages" content="126092187424650" />
        <meta property="fb:pages" content="1515773735319981" />
        <meta property="fb:pages" content="111803383382" />
        <meta property="fb:pages" content="931730943520729" />




<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wps/build/images/star-telegram/apple-touch-icon-144-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wps/build/images/star-telegram/apple-touch-icon-114-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wps/build/images/star-telegram/apple-touch-icon-72-precomposed.png">
<link rel="apple-touch-icon-precomposed" href="/wps/build/images/star-telegram/apple-touch-icon-57-precomposed.png">
<link rel="shortcut icon" href="/wps/build/images/star-telegram/favicon.png">




<script type="text/javascript"
            src="/wps/source/scripts/libs/require.js"></script>

<script type="text/javascript">
    var wpsConfig = {
        baseUrl: '/wps/source/scripts/src',
        urlArgs: 'misv=af1c179',
        paths: {
            'moment': '../libs/moment.min',
            'identity': '../libs/identityModulev3.min'
        },
        waitSeconds: 0
    };
    
    var wpsRequire = requirejs.config(wpsConfig);

</script>

<script>
    var mi = (function(mod) {
        mod.lazyloaders = mod.lazyloaders || [];
        return mod;
    })(mi || {});

    var rtkcategories = ["Sports","Baseball","Pro"];
</script>


    <script>mi.inMarket=false</script>



    <link href="/wps/build/css/theme.markets/star-telegram-fab618f5aa.css" rel="stylesheet" type="text/css"/>



<!--[if lt IE 9]>
<script type="text/javascript" src="//oss.maxcdn.com/html5shiv/3.7.3/html5shiv.min.js"></script>
<script type="text/javascript" src="//oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.9/es5-shim.min.js"></script>
<![endif]-->

<script type="text/javascript" src=" /wps/source/scripts/libs/jquery-1.10.2.min.js"></script>
<script type="text/javascript" src="/wps/build/js/mi-header-231ec30dc2.js"></script>



    <script type="text/javascript" src="/wps/source/scripts/libs/guid.js"></script>
    <script>
        wpsRequire(['identity'], function(IdentityModule) {
            $(window).load(function() {
                var identityCookieName = 'AccessToken';
                var accessTokenCookie = mi.getCookie(identityCookieName);
                
                if (!accessTokenCookie) {
                    var identityModule = new IdentityModule();
                    var identityPrefix = 'mcv4';
                    
                    $.getJSON('https://api.ipify.org?format=jsonp&callback=?')
                    .done(function(json) {
                        identityModule.GenerateIdentity(identityCookieName, identityPrefix, [json.ip]);
                    })
                    .fail(function() {
                        identityModule.GenerateIdentity(identityCookieName, identityPrefix, [getGuid()]);
                    });
                }
            });
        });
    </script>
    
        


        <!-- 
                
                
                
                
                

                
                
                
                

                
                
                

                
                

                
                
                
                
                
                
                

                
                
                
                

                
                
                
                


                
                    
                        
                        
                    

                
                

                
                    
                

                
                
                 -->


    



<script type="text/javascript">
mi.pageInfo.setConf({
'marketInfo.viewsizes':[{"Extra-Small":[0,0]},{"Large":[1200,600]},{"Medium":[992,300]},{"Small":[768,300]}],
'marketInfo.adsizes':{"outofpage":{},"wallpaper":{'1600x600':[1600,600],'None':[]},"floorboard":{'285x70':[285,70],'None':[]},"default":{'120x20':[120,20],'120x240':[120,240],'120x600':[120,600],'146x60':[146,60],'160x600':[160,600],'160x90':[160,90],'168x28':[168,28],'180x150':[180,150],'216x36':[216,36],'234x60':[234,60],'240x400':[240,400],'300x100':[300,100],'300x250':[300,250],'300x50':[300,50],'300x600':[300,600],'300x75':[300,75],'320x450':[320,450],'320x50':[320,50],'336x280':[336,280],'468x60':[468,60],'500x300':[500,300],'600x250':[600,250],'728x90':[728,90],'960x30':[960,30],'970x90':[970,90],'Billboard Flex':[[960,30],[970,90],[728,90],[970,250]],'Billboard Flex2':[[970,90],[970,250]],'Billboard Flex3':[[970,90],[970,250],[728,90]],'Flex Ad':[[300,250],[300,600]],'None':[],'Rising Star':[500,300],'Welcome Ad':[[300,250],[300,600],[550,480],[600,500]]} },'accuweather.apiKey':'2ce96fe9da724185a27db1e6a3ecf580',
'accuweather.dev':'false',
'accuweather.locationKey':'351196',
'accuweather.locationString':'Fort Worth',
'accuweather.partnerCode':'MCCLATCHY',
'cs.circ_phone':'800-776-7827 (STAR)',
'cs.circ_url':'http://www.star-telegram.com/myaccount',
'facebook.app.id':'155812681283151',
'financialContent.account':'startelegram',
'findnsave.tracking':'findnsave',
'headerDateDisplay':'false',
'legacy.affiliateId':'df000321',
'legacy.siteName':'dfw',
'marketInfo.CarsAFF':'ftworth',
'marketInfo.CarsSEO':'',
'marketInfo.JobsQSCTY':'Fort Worth',
'marketInfo.JobsQSSTS':'TX,US',
'marketInfo.JobsSEO':'',
'marketInfo.JobsSiteID':'cbcb_fwst',
'marketInfo.Jobslr':'CBCB_FWST',
'marketInfo.addcities':'Dallas, Arlington, Irving ',
'marketInfo.adretargeting.kill_list':'[&quot;simpli.fi&quot;]',
'marketInfo.allow_ads':'true',
'marketInfo.allow_nativo':'true',
'marketInfo.careerbuilder.lr':'CBCB_FWST',
'marketInfo.careerbuilder.mxjobsrchcriteria_rawwords':'outside+sales',
'marketInfo.careerbuilder.s_freshness':'30',
'marketInfo.careerbuilder.s_rawwords':'CustomField3:FTWORTHTJ',
'marketInfo.city':'Fort Worth',
'marketInfo.clipped_taxonomy':'Sports/Baseball/Pro',
'marketInfo.code':'FTW',
'marketInfo.county':'Tarrant County',
'marketInfo.domain':'star-telegram',
'marketInfo.followLinks':'true',
'marketInfo.kill_dealsaver':'true',
'marketInfo.location':'Fort Worth',
'marketInfo.market_identifier':'FTW.site_star-telegram',
'marketInfo.name':'Fort Worth Star Telegram',
'marketInfo.networkid':'7675',
'marketInfo.phone':'800-776-7827',
'marketInfo.product':'site',
'marketInfo.region':'Southwest',
'marketInfo.shortURL':'rangers',
'marketInfo.siteId':'58',
'marketInfo.sourcelevel':'texasrangers',
'marketInfo.state':'Texas',
'marketInfo.state_abbreviation':'TX',
'marketInfo.staticDirectory':'star-telegram',
'marketInfo.street_address':'808 Throckmorton St., Fort Worth, TX 76102',
'marketInfo.taxonomy':'Sports/Baseball/Pro//',
'marketInfo.webmaster_email':'online@star-telegram.com',
'marketInfo.zipcode':'76102',
'nativo.story.placements':'840666,748348,844387',
'nativo.video.placements':'869310,869309',
'obituaries.deathNoticeEmail':'obits@star-telegram.com',
'obituaries.deathNoticePhone':'817-390-7780',
'obituaries.deathNoticeUrl':'http://www.legacy.com/obituaries/dfw/obituary-place-an-obituary.aspx',
'pressPlus.zone':'De9IUjiwbtDoGVuBqaiiuC',
'publication.domain':'Star-Telegram.com',
'publication.mediadomain':'media.star-telegram.com',
'wishabi.bodyId':'834',
'wishabi.navId':'1482',
'wufoo.formID':'',
'marketInfo.pagelevel':'story',
});
</script>

<script type="text/javascript">
    var mistats = mistats || {};
    mistats.pagelevel="Story";
    mistats.cmsid="Story:215705830";
    mistats.pagename="Story:215705830|Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge";
    mistats.taxonomy="Sports|Baseball|Pro||";
    mistats.channel="Texas Rangers";
    mistats.contentsource="FortWorth|Jeff Wilson";
    mistats.pubdate="2018/07/28";
    mistats.moddate="2018/07/28 H22";
    mistats.keywords="Texas Rangers Houston Astros mlb baseball Ariel Jurado Rougned Odor Delino DeShields Cole Hamels Eddie Butler";
</script>


<script src="//media.star-telegram.com/misites/dfw/star-telegram.js"></script>


    <script type="text/javascript">
        var imgLazyLoadThreshold = 500;
    </script>



    
        
    <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [],
        googletag.cmd.push(function(){
            googletag.pubads().disableInitialLoad();
        });
        var getPreBidVarValue = function() {
            var constructedVar;
            var urlPathReg = /([^\/]*)\/*$/;
            var classifiedSearchReg = /homes|cars|jobs|search/;
            var urlPath = window.location.pathname;
            var lastUrlComponent = urlPath.match(urlPathReg)[1];
            var marketIdentifier = mi.pageInfo.getConf('marketInfo.market_identifier');
            var pageLevel = mi.pageInfo.getConf('marketInfo.pagelevel');
            var sourceLevel = mi.pageInfo.getConf('marketInfo.sourcelevel');
            var isArticle = new RegExp(/.html$/).test(urlPath);
            if ( lastUrlComponent === 'video' ) {
                pageLevel = 'videofront';
            } else if ( lastUrlComponent === 'galleries' ) {
                pageLevel = 'galleryfront';
            } else if ( lastUrlComponent.match(classifiedSearchReg) ) {
                pageLevel = pageLevel + '.' + sourceLevel;
            } else if (urlPath.search("/weather/") !== -1  && !isArticle) {
                pageLevel = 'sectfront.weather';
            } else if (urlPath.search("/latest-news/") !== -1 && !isArticle) {
                pageLevel = 'sectfront.latestnews';
            } else if (urlPath.search("-columns-blogs/") !== -1 && !isArticle) {
                pageLevel = 'blogfront';
            } else if (urlPath.search("/topics/") !== -1  && !isArticle) {
                pageLevel = 'sectfront';
            }
            if ( mi_Ads.env.outOfMarket.pageLevelOOM === true && mi_Ads.env.outOfMarket.serverOOMHeader === true ) {
                pageLevel = pageLevel + '-oom';
            }

            constructedVar = marketIdentifier + '.' + pageLevel;

            return constructedVar;
        };
        var preBidMarketPage = getPreBidVarValue();
    </script>
    <script src="//acdn.adnxs.com/prebid/c/7543_midwest/pb.js" async="true"></script>

    
    
    
    <script type="text/javascript" src="//ad.crwdcntrl.net/5/c=7436/pe=y/callback=extractPid"></script>




<script type="text/javascript">
    var getSubscribedFlag = false;
</script>


    
        
    
    <script type="text/javascript">
        getSubscribedFlag = checkUserSubscribed('MPPSessionId');
    </script>






    










  







<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",

  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "//www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html"
  },

  
  "headline": "Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge",
  "image": "https://www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/FREE_1140/0728%20Rangers%20Reaction%20art%201.JPG",
  "datePublished": "2018/07/28",
  "dateModified": "2018/07/28 H22","author": {
      "@type": "Person",
      "name": "Jeff Wilson"
    },"publisher": {
     "name": "Fort Worth Star-Telegram",
     "@type": "Organization",
     "logo": {
        "@type": "ImageObject",
        "url": "http://www.star-telegram.com/wps/build/images/star-telegram/amp-logo.png"
     }
  },
  
  "isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name": "star-telegram",
    "productID": "star-telegram.com:AllFTW-5008"
  },
  
  "description": "Rougned Odor collects an inside-the-park-homer as part of his 5-for-5 game that lifted his average to .270. That’s a far cry from where he was two months ago and last season, but the Texas Rangers don’t want their surging second baseman to forget his baseball demons.",
  "isAccessibleForFree": "False",
  "hasPart":
    {
      "@type": "WebPageElement",
      "isAccessibleForFree": "False",
      "cssSelector" : ".paywalled"
    }
}
</script>



<script>
    var _prx = window._prx || [];
    _prx.push(['cfg.SetNoAutoStart']);
</script>
<script src="https://s.ntv.io/serve/load.js" async></script>




    <script src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5" async></script>





<script type="text/javascript">
    const newsletterSuccess = (form) => {
        const $div = document.createElement('div');

        $div.classList.add('success');
        $div.innerHTML = "Thanks for subscribing; you should start to receive your newsletter shortly.";

        if(form.classList.contains('impact')){
            const $email = document.querySelector('.form-control');
            const $button = form.querySelector('.more-link-macro a');
            $email.parentNode.insertBefore($div, $email);
            form.querySelector('p').remove();
            $button.classList.add('success', 'disabled');
            $email.remove();
            $button.addEventListener('click', (e)=> {
                e.preventDefault();
                return false;
            });
        } else {
            form.innerHTML = '';
            form.appendChild($div);
        }
    };
    function callbackCaptcha(token){
        const $newsletterHomepage = document.querySelector('#newsletter .newsletter-cta-macro');
        const $newsletterSection = document.querySelector('#newsletter-signUpWidget');

        if($newsletterHomepage) {
            onSubmit($newsletterHomepage, token);
        }
        if($newsletterSection) {
            onSubmit($newsletterSection, token);
        }
    }
    function onSubmit(form, token){
        const data = JSON.parse(form.getAttribute('data-json'));

        data.captchaToken = token;
        form.removeAttribute('data-json');
        $.ajax({
            method: "POST",
            dataType: 'json',
            url: "https://api.mcclatchy.com/cheetahkit-api/recipient",
            data: data
        }).done(function (msg) {
            newsletterSuccess(form);
        }).fail(function (jqXHR, textStatus, errorThrown) {
            newsletterSuccess(form);
        });
    }
</script>
<script src='https://www.google.com/recaptcha/api.js' async defer></script>

    </head>

    

    

    
    
    

    <body class="story wps-body-main  paywalled">
        
    
        <header>
    <!-- WPS masthead -->
    
    
        <div class="hide">
            <div class="ad-widget" id="mn-gpt-1" adtype="outofpage" pkg="None" data-ad-policy="onPageLoad" audience="all" articleId="215705830"></div>
        </div>
    
    
     <div id="masthead-container">
        <div class="container">
            <div class="masthead-row">
                <div id="masthead-main">
                    <div id="masthead-logo">
                        <a href="/" target="_top">
                            <img src="/wps/build/images/star-telegram/logo-lg.png" alt="Fort Worth Star Telegram | Star-Telegram.com" class="img-responsive center-block" />
                            
                                <h1>Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge | Fort Worth Star-Telegram</h1>
                            
                        </a>
                    </div>
                    
<div id="quick-nav" class="hidden-xs">
    <ul class="nav navbar-nav">
        
            <li><a href="/news/#navlink=navbar">News</a></li>
        
            <li><a href="/sports/#navlink=navbar">Sports</a></li>
        
            <li><a href="http://www.legacy.com/obituaries/dfw/#navlink=navbar">Obituaries</a></li>
        
            <li><a href="http://classifieds.star-telegram.com/#navlink=navbar">Classifieds</a></li>
        
    </ul>

    <div id="site-search-lg" class="visible-lg">
        
        
    <form action="/search/" class="form-inline" id="site-search" role="search">

        <input type="text" name="q" class="form-control"/>
        <button class="input-group-addon" type="submit">
          <span class="glyphicon glyphicon-search"></span>
        </button>
    </form>

    </div>
    <div id="search-icon-sm-md" class="site-search dropdown visible-md visible-sm">
        <a href="#" class="btn btn-link" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="glyphicon glyphicon-search"></span></a>
        <ul class="dropdown-menu" role="menu" aria-labelledby="dLabel">
            <li class="input-group">
                
                
    <form action="/search/" class="form-inline" id="site-search" role="search">

        <input type="text" name="q" class="form-control" placeholder="Search the site"/>
        <button class="input-group-addon" type="submit">
          <span class="glyphicon glyphicon-search"></span>
        </button>
    </form>

            </li>
        </ul>
    </div>
</div>

                </div>
                
                    <div id="masthead-ad" class="visible-md visible-lg"><div class="ad-widget" id="mn-gpt-2" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="all" atf="y" defaultsize="Large" Large="234x60" Medium="234x60" Small="None" Extra-Small="None" articleId="215705830"></div></div>
                
            </div>
            <div id="main-nav-container">
                <div class="weather-container hidden-xs">
                    <div class="miWeather">
    <div class="miWeatherCurrent">
        
        <div class="mi-weather-conditions"><a href="/weather" title="Clear">
                    <img src="/wps/source/images/widgets/weather/small/33.png" alt="Clear"/>
                    <div class="mi-weather-conditions-temp">
                        87°
                    </div>
                </a>
            </div>
    </div>
</div>

                </div>
                <div id="login-subscribe" class="hidden-xs">
                    
<ul class="paywall-links">
    
        
        
        
        
        
        
            
        
        <script type="text/javascript">
            var userName = checkUserSubscribed('MPPUser');
            var signInOrAccountLink = '<li class="mpp-usericon"><a href="https://account.star-telegram.com/static/signin"> Sign In</a> </li>';
            var subscribeOrSignOutLink = '<li><a href="https://account.star-telegram.com/static/subscribe">Subscribe</a></li>';
            if ( getSubscribedFlag ) {
                if(userName) {
                    userName = JSON.parse(userName);
                }
                subscribeOrSignOutLink = '<li><a href="https://account.star-telegram.com/sign-out">Sign Out</a> </li>';
                if( userName && userName.firstName) {
                    signInOrAccountLink = '<li class="mpp-username mpp-usericon"><a href="https://account.star-telegram.com/my-account"> '+userName.firstName+'</a></li>';
                }else{
                    signInOrAccountLink = '<li class="mpp-usericon"><a href="https://account.star-telegram.com/my-account"> My Account</a></li>';
                }
            }
            if ( 1 ==1 ) {
                $(".hidden-xs ul.paywall-links").prepend(signInOrAccountLink," ",subscribeOrSignOutLink);
            }
            else {
                $("#navbar-collapse-1 ul.paywall-links").prepend(signInOrAccountLink," ",subscribeOrSignOutLink);
            }
        </script>
    
</ul>
                </div>
                
<div id="main-nav">
    <nav class="navbar navbar-default " role="navigation">
        <div class="navbar-header">
            <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
                <span class="nav-label hidden-xs">Full Menu</span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
            </button>
        </div>
        <div id="navbar-collapse-1" class="navbar-collapse collapse">
            <div id="search-icon-xs" class="site-search dropdown visible-xs">
                <a href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="glyphicon glyphicon-search"></span></a>
                <ul class="dropdown-menu" role="menu" aria-labelledby="dLabel">
                    <li class="input-group">
                        
                        
    <form action="/search/" class="form-inline" id="site-search" role="search">

        <input type="text" name="q" class="form-control" placeholder="Search the site"/>
        <button class="input-group-addon" type="submit">
          <span class="glyphicon glyphicon-search"></span>
        </button>
    </form>

                    </li>
                </ul>
            </div>
            <div class="weather-container visible-xs">
                <div class="miWeather">
    <div class="miWeatherCurrent">
        
        <div class="mi-weather-conditions"><a href="/weather" title="Clear">
                    <img src="/wps/source/images/widgets/weather/small/33.png" alt="Clear"/>
                    <div class="mi-weather-conditions-temp">
                        87°
                    </div>
                </a>
            </div>
    </div>
</div>

            </div>
            
<ul class="paywall-links">
    
        
        
        
        
        
        
            
        
        <script type="text/javascript">
            var userName = checkUserSubscribed('MPPUser');
            var signInOrAccountLink = '<li class="mpp-usericon"><a href="https://account.star-telegram.com/static/signin"> Sign In</a> </li>';
            var subscribeOrSignOutLink = '<li><a href="https://account.star-telegram.com/static/subscribe">Subscribe</a></li>';
            if ( getSubscribedFlag ) {
                if(userName) {
                    userName = JSON.parse(userName);
                }
                subscribeOrSignOutLink = '<li><a href="https://account.star-telegram.com/sign-out">Sign Out</a> </li>';
                if( userName && userName.firstName) {
                    signInOrAccountLink = '<li class="mpp-username mpp-usericon"><a href="https://account.star-telegram.com/my-account"> '+userName.firstName+'</a></li>';
                }else{
                    signInOrAccountLink = '<li class="mpp-usericon"><a href="https://account.star-telegram.com/my-account"> My Account</a></li>';
                }
            }
            if ( 2 ==1 ) {
                $(".hidden-xs ul.paywall-links").prepend(signInOrAccountLink," ",subscribeOrSignOutLink);
            }
            else {
                $("#navbar-collapse-1 ul.paywall-links").prepend(signInOrAccountLink," ",subscribeOrSignOutLink);
            }
        </script>
    
</ul>
            <ul class="nav navbar-nav">
                
                    
                        <li><a href="/customer-service/e-edition/#navlink=subnav">eEdition</a><li>
                    
                
                    
                        <li class="dropdown">
                            <a href="/customer-service/#navlink=subnav" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Customer Service
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/customer-service/#navlink=subnav">Customer Service</a></li>
            
        
            
                <li><a href="https://www.star-telegram.com/mobile/#navlink=subnav">Mobile &amp; Apps</a></li>
            
        
            
                <li><a href="http://x.email.star-telegram.com/ats/url.aspx?cr=663&amp;wu=12#navlink=subnav">Newsletters</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="nav-divider"></li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                News
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/news/local/#navlink=subnav">Local</a></li>
            
        
            
                <li><a href="/news/local/community/fort-worth/#navlink=subnav">Fort Worth</a></li>
            
        
            
                <li><a href="/news/local/community/arlington/#navlink=subnav">Arlington</a></li>
            
        
            
                <li><a href="/news/local/community/northeast-tarrant/#navlink=subnav">Northeast Tarrant</a></li>
            
        
            
                <li><a href="/news/state/texas/#navlink=subnav">Texas</a></li>
            
        
            
                <li><a href="/news/local/crime#navlink=subnav">Crime &amp; Courts</a></li>
            
        
            
                <li><a href="/news/politics-government/#navlink=subnav">Politics</a></li>
            
        
            
                <li><a href="https://www.star-telegram.com/news/politics-government/election/#navlink=subnav">Elections</a></li>
            
        
            
                <li><a href="/opinion/opn-columns-blogs/bud-kennedy/#navlink=subnav">Bud Kennedy</a></li>
            
        
            
                <li><a href="/news/special-reports/databases/#navlink=subnav">Databases</a></li>
            
        
            
                <li><a href="/news/nation-world/#navlink=subnav">Nation and World</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Sports
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/sports/nfl/dallas-cowboys/#navlink=subnav">Cowboys</a></li>
            
        
            
                <li><a href="/sports/mlb/texas-rangers/#navlink=subnav">Rangers</a></li>
            
        
            
                <li><a href="/sports/college/big-12/texas-christian-university/#navlink=subnav">TCU</a></li>
            
        
            
                <li><a href="/sports/spt-columns-blogs/mac-engel/#navlink=subnav">Mac Engel</a></li>
            
        
            
                <li><a href="/sports/college/#navlink=subnav">Colleges</a></li>
            
        
            
                <li><a href="/sports/nba/dallas-mavericks/#navlink=subnav">Mavericks</a></li>
            
        
            
                <li><a href="/sports/nascar-auto-racing/#navlink=subnav">Motorsports</a></li>
            
        
            
                <li><a href="/sports/nhl/dallas-stars/#navlink=subnav">Stars</a></li>
            
        
            
                <li class="dropdown-header">High School Sports</li>
            
        
            
                <li><a href="/sports/dfwvarsity/schedules/#navlink=subnav">Scores &amp; Schedules</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/#navlink=subnav">All Sports</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/prep-football/#navlink=subnav">Football</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/prep-baseball/#navlink=subnav">Baseball</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/prep-softball/#navlink=subnav">Softball</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/prep-volleyball/#navlink=subnav">Volleyball</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/boys-prep-basketball/#navlink=subnav">Boys Basketball</a></li>
            
        
            
                <li><a href="/sports/dfwvarsity/girls-prep-basketball/#navlink=subnav">Girls Basketball</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Opinion
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/opinion/editorials/#navlink=subnav">Editorials</a></li>
            
        
            
                <li><a href="/opinion/letters-to-the-editor/#navlink=subnav">Letters</a></li>
            
        
            
                <li><a href="/opinion/letters-to-the-editor/submit-letter/#navlink=subnav">Submit a letter</a></li>
            
        
            
                <li><a href="/opinion/letters-to-the-editor/cheers-jeers/#navlink=subnav">Cheers and Jeers</a></li>
            
        
            
                <li><a href="/opinion/letters-to-the-editor/submit-letter/#navlink=subnav">Submit a Cheer or Jeer</a></li>
            
        
            
                <li><a href="/opinion/opn-columns-blogs/bud-kennedy/#navlink=subnav">Bud Kennedy</a></li>
            
        
            
                <li><a href="/opinion/opn-columns-blogs/cynthia-m-allen/#navlink=subnav">Cynthia M. Allen</a></li>
            
        
            
                <li><a href="/opinion/opn-columns-blogs/other-voices/#navlink=subnav">Other Voices</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Business
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/news/business/#navlink=subnav">Business</a></li>
            
        
            
                <li><a href="https://www.star-telegram.com/news/business/growth/#navlink=subnav">Growth</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Entertainment
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/entertainment/restaurants/#navlink=subnav">Restaurants</a></li>
            
        
            
                <li><a href="/entertainment/arts-culture/#navlink=subnav">Arts &amp; Culture</a></li>
            
        
            
                <li><a href="/entertainment/movies/#navlink=subnav">Movies</a></li>
            
        
            
                <li><a href="/entertainment/events/things-to-do/#navlink=subnav">Things To Do</a></li>
            
        
            
                <li><a href="/entertainment/music/#navlink=subnav">Music</a></li>
            
        
            
                <li><a href="/entertainment/nightlife/#navlink=subnav">Nightlife</a></li>
            
        
            
                <li><a href="/entertainment/nightlife/party-pics/#navlink=subnav">Party Pics</a></li>
            
        
            
                <li><a href="/entertainment/horoscopes/#navlink=subnav">Horoscopes</a></li>
            
        
            
                <li><a href="/entertainment/comics/#navlink=subnav">Comics</a></li>
            
        
            
                <li><a href="/customer-service/contests-promotions/#navlink=subnav">Contests</a></li>
            
        
            
                <li><a href="http://games.star-telegram.com/#navlink=subnav">Puzzles and Games</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Living
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/living/food-drink/#navlink=subnav">Food &amp; Drink</a></li>
            
        
            
                <li><a href="/entertainment/arts-culture/#navlink=subnav">Arts</a></li>
            
        
            
                <li><a href="/living/health-fitness/#navlink=subnav">Health &amp; Fitness</a></li>
            
        
            
                <li><a href="/living/indulge#navlink=subnav">Indulge</a></li>
            
        
            
                <li><a href="/living/keller-magazine/#navlink=subnav">The Keller Magazine</a></li>
            
        
            
                <li><a href="/living/home-garden/neil-sperry/#navlink=subnav">Neil Sperry</a></li>
            
        
            
                <li><a href="/living/liv-columns-blogs/social-eyes/#navlink=subnav">Social Eyes</a></li>
            
        
            
                <li><a href="http://www.uclick.com/client/ftw/da/#navlink=subnav">Dear Abby</a></li>
            
        
            
                <li><a href="https://www.star-telegram.com/weddings/#navlink=subnav">Weddings</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Community News
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/news/local/community/arlington-citizen-journal/#navlink=subnav">Arlington Citizen-Journal</a></li>
            
        
            
                <li><a href="/news/local/community/keller-citizen/#navlink=subnav">Keller Citizen</a></li>
            
        
            
                <li><a href="/news/local/community/northeast-tarrant/#navlink=subnav">Star-Telegram Northeast</a></li>
            
        
            
                <li><a href="/news/local/community/mansfield-news-mirror/#navlink=subnav">Mansfield News-Mirror</a></li>
            
        
            
                <li><a href="/news/local/community/weatherford-star-telegram/#navlink=subnav">Weatherford Star-Telegram</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                La Estrella
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="/la-estrella/#navlink=subnav">La Estrella</a></li>
            
        
            
                <li><a href="/la-estrella/locales/#navlink=subnav">Locales</a></li>
            
        
            
                <li><a href="/la-estrella/noticias/#navlink=subnav">Noticias</a></li>
            
        
            
                <li><a href="/la-estrella/deportes/#navlink=subnav">Deportes</a></li>
            
        
            
                <li><a href="/la-estrella/entretenimiento/#navlink=subnav">Entretenimiento</a></li>
            
        
            
                <li><a href="/la-estrella/contactenos/#navlink=subnav">Contáctenos</a></li>
            
        
            
                <li><a href="http://media.star-telegram.com/static/marketing/mediakit/pdf/2016laestrella.pdf#navlink=subnav">Media Kit</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Obituaries
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="http://www.legacy.com/obituaries/dfw/#navlink=subnav">Today&#39;s Obituaries</a></li>
            
        
            
                <li><a href="https://www.star-telegram.com/news/local/obituaries/#navlink=subnav">Obituaries in the News</a></li>
            
        
            
                <li><a href="http://www.legacy.com/obituaries/dfw/obituary-place-an-obituary.aspx#navlink=subnav">Submit an Obituary</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li class="nav-divider"></li>
                    
                
                    
                        <li><a href="https://www.star-telegram.com/weddings/#navlink=subnav">Weddings</a><li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Must Know
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=94#navlink=subnav">Hispanic Heritage</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=92#navlink=subnav">Cancer Awareness</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=91#navlink=subnav">Healthy Lifestyle</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=90#navlink=subnav">Dining, Entertaining</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=89#navlink=subnav">Breast Cancer Awareness</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=87#navlink=subnav">Think Green</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=102#navlink=subnav">Money Matters</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=98#navlink=subnav">All About Pets</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=59#navlink=subnav">Careers and Business</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=120#navlink=subnav">Health and Wellness</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=119#navlink=subnav">How To...</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=117#navlink=subnav">Women Today</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=116#navlink=subnav">Family and Parenting</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=83#navlink=subnav">Easy Living Tips</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=114#navlink=subnav">Lawn and Garden</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=99#navlink=subnav">Giving Back</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=47#navlink=subnav">Men Today</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=111#navlink=subnav">On the Road 1</a></li>
            
        
            
                <li><a href="http://startelegram.qrsite.com/esection.php?sect=96#navlink=subnav">On the Road 2</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li><a href="http://www.legalnotice.org/pl/startelegram/landing1.aspx#navlink=subnav">Public Notices</a><li>
                    
                
                    
                        <li class="dropdown">
                            <a href="#" class="dropdown-toggle" data-toggle="dropdown">
                                <span class="glyphicon glyphicon-chevron-left"></span>
                                Local Deals
                                <span class="glyphicon glyphicon-chevron-right"></span>
                                <b class="caret"></b>
                            </a>
                            
    <ul class="dropdown-menu">
        
            
                <li><a href="http://findnsave.star-telegram.com/#navlink=subnav">Shopping</a></li>
            
        
            
                <li><a href="http://dfw.findnsave.com/PrintCoupons#navlink=subnav">Grocery Coupons</a></li>
            
        
    </ul>

                        </li>
                    
                
                    
                        <li><a href="/cars/#navlink=subnav">Cars</a><li>
                    
                
                    
                        <li><a href="https://jobs.star-telegram.com#navlink=subnav">Jobs</a><li>
                    
                
                    
                        <li><a href="http://www.startmoonlighting.com/mni/Fort-Worth-Star-Telegram/?utm_source=Fort-Worth-Star-Telegram&amp;utm_medium=navweblink&amp;utm_campaign=MNI#navlink=subnav">Moonlighting</a><li>
                    
                
                    
                        <li><a href="/homes/#navlink=subnav">Homes</a><li>
                    
                
                    
                        <li><a href="http://classifieds.star-telegram.com/#navlink=subnav">Classifieds</a><li>
                    
                
                    
                        <li><a href="/mobile/#navlink=subnav">Mobile &amp; Apps</a><li>
                    
                
                    
                        <li class="nav-divider"></li>
                    
                
            </ul>
        </div>
    </nav>
</div>
<script type="text/javascript">
    $(document).ready(function () {
        mi.mainNav.init();
    });
</script>

            </div>
        </div>
    </div>
    
</header>

    

        
    
        



















    






    


    


    



<div class="container ">
    <div id="leaderboard-ad" class="ad border-bottom">
        <!-- mobile-leaderboard class is integrated with sticky-leaderboard.js -->
        <div class="visible-xs mobile-leaderboard">
            <div class="ad-widget" id="mn-gpt-3" adtype="default" pkg="b" data-ad-policy="onPageLoad" audience="all" atf="y" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="320x50" articleId="215705830"></div>
        </div>
        <div class="hidden-xs">
            <div class="ad-widget" id="mn-gpt-4" adtype="default" pkg="d" data-ad-policy="onPageLoad" audience="all" atf="y" defaultsize="Large" Large="728x90" Medium="728x90" Small="728x90" Extra-Small="None" articleId="215705830"></div>
        </div>
    </div>
</div>
<section class="container story" role="main">
    <div class="row story-rail-wrapper">
        
        <div class="wide-rail">
            
                




    


    




    
    <div class="lead-item ">
        
            






    <div class="img-container picture ">   
        <picture>
            <!--[if IE 9]><video style="display: none;"><![endif]-->
            <source srcset="//www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_1140/0728%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 992px)">
            <source srcset="//www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_960/0728%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 768px)">
            <source srcset="//www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_768/0728%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 601px)">
            <source srcset="//www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_640/0728%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 441px)">
            <source srcset="//www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_480/0728%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 320px)">
            <!--[if IE 9]></video><![endif]-->
            
            <img class="responsive-image"  srcset="//www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_1140/0728%20Rangers%20Reaction%20art%201.JPG" alt="Texas Rangers’ Rougned Odor, right, watches his second home run of the night in front of Houston Astros catcher Max Stassi during the seventh inning of a baseball game Saturday, July 28, 2018, in Houston. (AP Photo/Michael Wyke)" title="Texas Rangers’ Rougned Odor, right, watches his second home run of the night in front of Houston Astros catcher Max Stassi during the seventh inning of a baseball game Saturday, July 28, 2018, in Houston. (AP Photo/Michael Wyke)" />
            
        </picture> 

</div>

            
                <div class="caption">
                    
    
        <span class="caption-text">Texas Rangers’ Rougned Odor, right, watches his second home run of the night in front of Houston Astros catcher Max Stassi during the seventh inning of a baseball game Saturday, July 28, 2018, in Houston. (AP Photo/Michael Wyke) </span>
    
    
        <span class="photographer">Michael Wyke</span>
    
    
        <span class="credits">The Associated Press</span>
    

                </div>
            
        
        
            <div class="lead-caption">
                
                    
                        
    
        <span class="caption-text">Texas Rangers’ Rougned Odor, right, watches his second home run of the night in front of Houston Astros catcher Max Stassi during the seventh inning of a baseball game Saturday, July 28, 2018, in Houston. (AP Photo/Michael Wyke) </span>
    
    
        <span class="photographer">Michael Wyke</span>
    
    
        <span class="credits">The Associated Press</span>
    

                    
                
            </div>
        
    </div>
    <script>
        jQuery(document).ready(function () {
            mi.leadAssets.init();
        });
    </script>

            
            
    
    
    

            <div id="story-header">
                <h2 class="heading section-main-heading link">
                    <a href="//www.star-telegram.com/sports/mlb/texas-rangers/">Texas Rangers</a>
                </h2>

                <h3 class="title">Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge</h3>
            </div>
            <div id="story-body-items"><div class="byline element-spacing-small"><p><span class="ng_byline_name">By Jeff Wilson</span></p><p><span class="ng_byline_email">
                                            <a href="mailto:jwilson@star-telegram.com">jwilson@star-telegram.com</a>
                                        </span></p></div>
                    <div class="share-tools-wrapper">
                        









    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    
        
    

    

    

    

    

    

    

    

    

    

    

    

    

    

    











<ul class="share-icons">
    <li class="facebook">
        
            
                <a class="facebook-share" title="Share on Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html" onclick="mi.articleShareTools.popupFunction(this.href, 5637);return false;"></a>
            
        
        <div class="glyphicon glyphicon-facebook"></div>
    </li>
    <li class="twitter">
        
            <a title="Share on Twitter" href="https://twitter.com/share?text=Rangers+Reaction:+The+hits+keeps+coming+for+Odor,+thanks+to+recapturing+his+edge&amp;url=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html" onclick="mi.articleShareTools.popupFunction(this.href, 5638);return false;"></a>
        
        <div class="glyphicon glyphicon-twitter"></div>
    </li>
    
    <li class="email">
        
            <a title="Share by Email" href="mailto:?subject=Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge&body=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html" onclick="nextbee.credit_share_articles(5254);"></a>
        
        <div class="glyphicon glyphicon-envelope"></div>
    </li>
    <li class="more" onClick="return true">
        <ul class="share-options">
            
                <li class="linked-in"><a id="linkedInId" title="Share on LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html&title=Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge"><span class="glyphicon glyphicon-linkedin"></span>LinkedIn</a></li>
            
            
                <li class="google"><a title="Share on Google Plus" href="https://plus.google.com/share?url=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html" onclick="mi.articleShareTools.popupFunction(this.href, 5296);return false;"><span class="glyphicon glyphicon-google-plus"></span>Google+</a></li>
            
            
                <li class="pinterest"><a id="pinterestId" title="Share on Pinterest" href="https://www.pinterest.com/pin/create/button/?url=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html&description=Rangers Reaction: The hits keeps coming for Odor, thanks to recapturing his edge&media=https://www.star-telegram.com/latest-news/gtwo44/picture215723010/alternates/LANDSCAPE_1140/0728%20Rangers%20Reaction%20art%201.JPG"><span class="glyphicon glyphicon-pinterest-p"></span>Pinterest</a></li>
            
            <li class="reddit"><a title="Share on Reddit" href="https://www.reddit.com/submit?url=https://www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html"><span class="glyphicon glyphicon-reddit"></span>Reddit</a></li>
            <li class="print"><a title="Print" href="javascript:window.print();"><span class="glyphicon glyphicon-print"></span>Print</a></li>
            <li class="reprints"><a title="Reprints" href="https://www.mcclatchyreprints.com">Order Reprint of this Story</a></li>
        </ul>
        <div class="glyphicon glyphicon-share"></div>
    </li>
</ul>
<script type="text/javascript">
    $(document).ready(function () {
        mi.articleShareTools.init({
            nextLinkedin: '5324',
            nextPinterest: '5275'
        });
        mi.socialSharingScroll.init();
    });
</script>
                    </div>
                

                <div class="published-date-widget">
                    <p class="published-date">
                        <span id="publish_date">
                            July 28, 2018 10:21 PM
                        </span>
                    </p>
                    <p class="published-date">
                        
                            <span id="update_date">
                               
                            </span>
                        
                    </p>
                </div>

                <div class="dateline-storybody">
                    
                        <span class="dateline">
                            HOUSTON
                        </span>
                    
                    <div id="story-target" class="clearfix">
                        <div id="content-body-" class="content-body">
                            
                            
                            
                            
                                
                                    <p dir="ltr">Adrian Beltre didn’t make it easy on the beat guys Saturday afternoon, nor did we expect anything less.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">He starts out giving short, to-the-point answers before graduating to answers with some meat on them. The sessions usually end with him saying he will talk to use in three or four weeks, though he knows darn well we’ll be back at his locker every day until there’s resolution with his trade situation.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">After Saturday, I might have to <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article214999270.html" target="_self">change my tune on if he will be dealt</a>. Before he spoke, my feeling was he wouldn’t accept a trade. Now, it’s 50-50.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">The thinking here is that he will accept a trade if he can get assurances from general manager Jon Daniels that the Rangers will re-sign him for 2019. If Daniels waffles, Beltre will reject a trade.</p>
                                    
                                        
    
        <form id="newsletter-signUpWidget"
              data-newsletterUrl="https://api.mcclatchy.com/cheetahkit-api/recipient"
              data-newsletterSiteName="star-telegram"
              data-newsletterPreferenceListNames="[{&quot;name&quot;:&quot;morning newsletter&quot;,&quot;title&quot;:&quot;Today&#39;s top news by email&quot;,&quot;headline&quot;:&quot;The local news you need to start your day&quot;},{&quot;name&quot;:&quot;breaking newsletter&quot;,&quot;title&quot;:&quot;Breaking News&quot;,&quot;headline&quot;:&quot;Be the first to know when big news breaks&quot;}]"
              data-isNewsletterEnabled="true"
              data-newsletterSuccess="Thanks for subscribing; you should start to receive your newsletter shortly."
              class="newsletter-signup newsletter-cta-macro hidden" method="POST">
            <input type="hidden" value="" id="newsletterType">
            <input id="s_email_address" name="s_email_address" value="" placeholder="Enter Email Address"
                   type="email">
            <div class="g-recaptcha" data-sitekey="6LcCJGUUAAAAADAmkD2iQN_k8a6FCpgo2VBei6su" data-callback="callbackCaptcha" data-size="invisible"></div>
            <button type="submit" disabled id="newsletterSignupSubmit" class="btn btn-default">
                SIGN UP</button>
        </form>
    



    <div id="story-cta-widget" class="subscription-cta-widget cta-fullwidth hidden">
        <h2 class="widget-title">Be the first to know.</h2>
        <p class="widget-subhead">No one covers what is happening in our community better than we do. And with a digital subscription, you&#39;ll never miss a local story.</p>
        <div class="btn btn-primary widget-button">
            <a href="https://account.star-telegram.com/subscribe/create?param=fHpCAUU=&amp;cid=CTA_.991mo_firsttoknow">SIGN ME UP!</a>
        </div>
    </div>

<script>
    /* function enableSubmitBtn(token){
         mi.calltoActionCtrl.sendResponse(token);
     }*/
    jQuery(document).ready(function () {
        mi.calltoActionCtrl.init(true);
    });
</script>
                                        
                                    
                                    
                                
                                    <p dir="ltr">That puts the onus on Daniels <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article213753724.html" target="_self">to find a deal</a> good enough for the Rangers with the right contender for Beltre. It needs to be a postseason lock, like the Cleveland Indians, instead of a club that might win a wild-card spot.</p>
                                    
                                    
                                    
                                        
    
    
    <div class="ad visible-xs">
        <div class="ad-widget" id="mn-gpt-5" adtype="default" pkg="c" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="300x250" articleId="215705830"></div>
    </div>

                                        
                                    
                                
                                    <p dir="ltr">The Houston Astros are a lock. Daniels wouldn’t, would he? Beltre wouldn’t, would he?</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Well, the Rangers don’t have any remaining games this season with Houston after Sunday, when they go for a series sweep, so at least they wouldn’t have to face him in the rival’s uniform.</p>
                                    
                                        
                                        
                                            
    
    
    

    
        <div class="s2nPlayer element-spacing-large k-JAUKIa5W" data-type="float"></div>
        <script type="text/javascript" src="https://embed.sendtonews.com/player3/embedcode.js?fk=JAUKIa5W&cid=6324&offsetx=0&offsety=0&floatwidth=400&floatposition=top-right" data-type="s2nScript"></script>
    

                                        
                                    
                                    
                                    
                                
                                    <p dir="ltr">So they’ve got that going for them, which is nice.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Here’s some Rangers Reaction from a 7-3 victory.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">1. When Rougned Odor was <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article27987730.html" target="_self">optioned to Triple A Round Rock in 2015</a>, one of the main reasons behind the decision was for him to get his edge back.<br><br></p>
                                    
                                    
                                    
                                        
    
    
    <div class="ad visible-xs">
        <div class="ad-widget" id="mn-gpt-6" adtype="default" pkg="e" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="300x250" articleId="215705830"></div>
    </div>

                                        
                                    
                                
                                    <p dir="ltr">As one team official put it, the Rangers wanted him to get back to being a, well, seven-letter curse word that starts with A.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">A month later, that’s what he was again. He was confident. He played with his chest sticking out. He rubbed opposing teams and fans the wrong way.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">That’s what the Rangers are seeing from their second baseman more and more as he continues his surge to relevancy. <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article214709675.html" target="_self">The player who batted .204 last season and was at .171 in late May</a> is up to .270 after a 5-for-5 night that included two homers — an inside-the-park job and a conventional shot over the right-field wall.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">He also raced home for a key run in the ninth on a chopper against a drawn-in infield. Odor is doing it all, and he still contends that he doesn’t feel good yet.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">The goal now is to maintain it. While he might be on the verge of making 2017 an aberration, he can’t forget his past.</p>
                                    
                                    
                                    
                                        
    
    
        




    <div id="story-related" class="story-related element-spacing-large">
        <h2>Related stories from  Fort Worth Star Telegram</h2>
        <div id="related-links">
            
                
                    
                    <article>
                        <div class="teaser">
                            
                                <a  href="//www.star-telegram.com/sports/mlb/texas-rangers/article215714150.html">
                                    
                                        






    <div class="img-container picture ">   
        <picture>
            <!--[if IE 9]><video style="display: none;"><![endif]-->
            <source srcset="//www.star-telegram.com/latest-news/s7694e/picture215714300/alternates/LANDSCAPE_1140/0728%20Rangers%20Beltre%20art%202.JPG" media="(min-width: 992px)">
            <source srcset="//www.star-telegram.com/latest-news/s7694e/picture215714300/alternates/LANDSCAPE_960/0728%20Rangers%20Beltre%20art%202.JPG" media="(min-width: 768px)">
            <source srcset="//www.star-telegram.com/latest-news/s7694e/picture215714300/alternates/LANDSCAPE_768/0728%20Rangers%20Beltre%20art%202.JPG" media="(min-width: 601px)">
            <source srcset="//www.star-telegram.com/latest-news/s7694e/picture215714300/alternates/LANDSCAPE_640/0728%20Rangers%20Beltre%20art%202.JPG" media="(min-width: 441px)">
            <source srcset="//www.star-telegram.com/latest-news/s7694e/picture215714300/alternates/LANDSCAPE_480/0728%20Rangers%20Beltre%20art%202.JPG" media="(min-width: 320px)">
            <!--[if IE 9]></video><![endif]-->
            
            <img class="responsive-image"  srcset="//www.star-telegram.com/latest-news/s7694e/picture215714300/alternates/LANDSCAPE_1140/0728%20Rangers%20Beltre%20art%202.JPG" alt="Beltre’s deadline conflict: Win elsewhere vs. loyalty to Rangers" title="" />
            
        </picture> 

</div>

                                    
                                    
                                </a>
                            
                            <h4 class="title">
                                <a href=//www.star-telegram.com/sports/mlb/texas-rangers/article215714150.html>Beltre’s deadline conflict: Win elsewhere vs. loyalty to Rangers</a>
                            </h4>
                        </div>
                    </article>
                    
                
            
                
                    
                    <article>
                        <div class="teaser">
                            
                                <a  href="//www.star-telegram.com/sports/mlb/texas-rangers/article215705725.html">
                                    
                                        






    <div class="img-container picture ">   
        <picture>
            <!--[if IE 9]><video style="display: none;"><![endif]-->
            <source srcset="//www.star-telegram.com/latest-news/cbkv58/picture215711810/alternates/LANDSCAPE_1140/0728%20Rangers%20art%201.JPG" media="(min-width: 992px)">
            <source srcset="//www.star-telegram.com/latest-news/cbkv58/picture215711810/alternates/LANDSCAPE_960/0728%20Rangers%20art%201.JPG" media="(min-width: 768px)">
            <source srcset="//www.star-telegram.com/latest-news/cbkv58/picture215711810/alternates/LANDSCAPE_768/0728%20Rangers%20art%201.JPG" media="(min-width: 601px)">
            <source srcset="//www.star-telegram.com/latest-news/cbkv58/picture215711810/alternates/LANDSCAPE_640/0728%20Rangers%20art%201.JPG" media="(min-width: 441px)">
            <source srcset="//www.star-telegram.com/latest-news/cbkv58/picture215711810/alternates/LANDSCAPE_480/0728%20Rangers%20art%201.JPG" media="(min-width: 320px)">
            <!--[if IE 9]></video><![endif]-->
            
            <img class="responsive-image"  srcset="//www.star-telegram.com/latest-news/cbkv58/picture215711810/alternates/LANDSCAPE_1140/0728%20Rangers%20art%201.JPG" alt="Kela receiving most interest as Rangers approach Tuesday’s deadline" title="" />
            
        </picture> 

</div>

                                    
                                    
                                </a>
                            
                            <h4 class="title">
                                <a href=//www.star-telegram.com/sports/mlb/texas-rangers/article215705725.html>Kela receiving most interest as Rangers approach Tuesday’s deadline</a>
                            </h4>
                        </div>
                    </article>
                    
                
            
                
                    
                    <article>
                        <div class="teaser">
                            
                                <a  href="//www.star-telegram.com/sports/mlb/texas-rangers/article215690895.html">
                                    
                                        






    <div class="img-container picture ">   
        <picture>
            <!--[if IE 9]><video style="display: none;"><![endif]-->
            <source srcset="//www.star-telegram.com/latest-news/g88jyi/picture215690905/alternates/LANDSCAPE_1140/0727%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 992px)">
            <source srcset="//www.star-telegram.com/latest-news/g88jyi/picture215690905/alternates/LANDSCAPE_960/0727%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 768px)">
            <source srcset="//www.star-telegram.com/latest-news/g88jyi/picture215690905/alternates/LANDSCAPE_768/0727%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 601px)">
            <source srcset="//www.star-telegram.com/latest-news/g88jyi/picture215690905/alternates/LANDSCAPE_640/0727%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 441px)">
            <source srcset="//www.star-telegram.com/latest-news/g88jyi/picture215690905/alternates/LANDSCAPE_480/0727%20Rangers%20Reaction%20art%201.JPG" media="(min-width: 320px)">
            <!--[if IE 9]></video><![endif]-->
            
            <img class="responsive-image"  srcset="//www.star-telegram.com/latest-news/g88jyi/picture215690905/alternates/LANDSCAPE_1140/0727%20Rangers%20Reaction%20art%201.JPG" alt="Rangers Reaction: Hamels trade in ’15 a success. How does trade to Cubs look?" title="" />
            
        </picture> 

</div>

                                    
                                    
                                </a>
                            
                            <h4 class="title">
                                <a href=//www.star-telegram.com/sports/mlb/texas-rangers/article215690895.html>Rangers Reaction: Hamels trade in ’15 a success. How does trade to Cubs look?</a>
                            </h4>
                        </div>
                    </article>
                    
                
            
        </div>
    </div>

    
    <div class="ad visible-xs">
        <div class="ad-widget" id="mn-gpt-7" adtype="default" pkg="f" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="300x250" articleId="215705830"></div>
    </div>

                                        
                                    
                                
                                    <p dir="ltr">“I hope he never forgets about those demons,” manager Jeff Banister said. “Obviously, you want him to continue playing with the energy he’s playing with and the approach he’s playing with. However, when you just completely discount what he’s gone through, then he doesn’t stay sharp and maintain that edge.”</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Odor said that he has become engrained enough in his new approach and routine that he can tell when he’s back to his 2017 ways. He quickly snaps out of it.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">With the help of the two hitting coaches and <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article214943350.html" target="_self">Shin-Soo Choo</a>, whose remarkable discipline can be of help to any hitter, Odor is able to keep his mind right.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">“Just stay focused,” he said. “Stay focused with my plan. Stay focused with every pitch and keep looking for my pitch. When I stay focused on my plan, I feel much better.”</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">On the inside-the-park homer in the fifth inning, Odor sent a drive into center field. He initially thought it was a home run until he saw George Springer racing for it. Odor hit the jets around first and stomped the gas pedal when he saw the ball carom across the warning track after hitting a section of wall angled to left field.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">“When I saw the ball hit the wall, I was like, ‘I’m going home,’” Odor said.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">It was the first inside-the-park homer of his career as well as his first career five-hit game. He has nine home runs, five in July and eight in his past 30 games.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">But it’s not about the long ball, as it appeared to be last season. It’s about getting his edge back but not forgetting the demons he battled last season.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">2. Mixed messages came Friday from the Rangers’ top two baseball people regarding Ariel Jurado.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">General manager Jon Daniels announced that the right-hander would be promoted from Double A Frisco to take Cole Hamels spot in the rotation, and then that spot would be resolved going forward.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Banister, though, said that Jurado was in the rotation to stay.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">After what he did Saturday, Jurado left no doubt what should be done.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">He allowed one run on two hits and a walk over six efficient innings for his first career victory in his second career start. The lone run came on a Springer homer to start the fourth after Jurado retired the first nine Astros he faced.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Jurado came as has been advertised for a few seasons. He worked quickly, used his sinker to keep the ball on the ground, and didn’t give in after the Springer homer or when the Astros threatened in the sixth.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">“Really an exceptional sinker,” Banister said. “A very solid night for a young pitcher. A lot of confidence. He stayed with his game plan. There were just a couple moments when he got away from that.”</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">It’s not dominant top-of-the-rotation stuff, but Jurado will find a place in the rotation if he can command his fastball and work quickly. He said that he was able to keep his fastball down, which he couldn’t do in his MLB debut in May at Chicago.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Jurado has jumped to the top of the class of minor-league pitchers who are knocking on the big leagues. <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article213691989.html" target="_self">Yohander Mendez</a> is working his way back and is on the radar for a September call-up, but after that things thin out considerably.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">When the off-season rolls around and the Rangers try to fill four rotation spots, Jurado and Mendez will get consideration. So will <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article215705825.html" target="_self">Eddie Butler</a>, part of <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article215643890.html" target="_self">the return for the Hamels trade</a>.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Why would the Rangers put him in the deal if they weren’t going to give him a chance to be a starter? Seems like a very solid bet for the 2019 rotation to me.</p>
                                    
                                    
                                    
                                
                                    <p>Pending trades and the return of Doug Fister, Jurado looks to be solidly in place for the time being.</p>
                                    
                                    
                                    
                                
                                    <p></p>
                                    
                                    
                                    
                                
                                    <div class="embed-media inline-video"><div id="video-detail-215718635-1532834546610" class="media-wrap ">
    <div id="playerWrap-215718635-1532834546610" class="video-media vjs-wrapper">
        <video id="player-215718635-1532834546610" class="video-js vjs-16-9 mi-videojs brightcoveEnabled" data-url="https://www.star-telegram.com/latest-news/article215718635.html" data-title="New Rangers pitcher Eddie Butler has eyes on starting rotation" data-video-id="5815159613001" data-account="5615998025001" data-key="BCpkADawqM2rwsIfO8wUl9c9hB38MbOjlZotXHej_azhC4fpzDrgG_yDynchxYvWK82c6Tp7UrVLjnutTT3oczSjC6E62MdY8OIcX-N2LCEzzcGijSEWAcTMcilqgeTcauuTaCLWXjJ9Qwae" data-publication="star-telegram" data-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;description_url=https%3A%2F%2Fwww.star-telegram.com%2Flatest-news%2Farticle215718635.html&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;iu=%2F7675%2FFTW.site_star-telegram%2FSports%2FBaseball%2FPro&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;hl=en&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vid_t=New%20Rangers%20pitcher%20Eddie%20Butler%20has%20eyes%20on%20starting%20rotation&amp;vpa=0&amp;vpmute=0&amp;adtest=false&amp;ciu_szs=300x250&amp;cmsid=2475993&amp;vid=5815159613001&amp;cust_params=sect%3DTexas%20Rangers" data-asset-type="video" data-video-auto-play="false" data-video-type="inline" crossorigin="anonymous">
               </video>
        <div class="vjs-share">
    <button class="vjs-share-trigger">
        <span class="vjs-share-text">SHARE</span>
        <span class="vjs-share-icon glyphicon glyphicon-share"></span>
    </button>
</div>
<div class="vjs-overlay">
    <div class="vjs-overlay__sharing video-share-icons">
        <a href="" target="blank" class="vjs-overlay-sharing_item facebook-share glyphicon glyphicon-facebook"></a>
        <a href="" target="blank" class="vjs-overlay-sharing_item twitter-share glyphicon glyphicon-twitter"></a>
        <a href="mailto:?&amp;subject=&amp;body=" target="blank" class="vjs-overlay-sharing_item email-share glyphicon glyphicon-envelope"></a>
        <a href="#" class="vjs-overlay-sharing_item glyphicon glyphicon-code vjs-overlay-sharing__embed"></a>
        <form class="vjs-sharing__link">
            <textarea class="overlay-embed-share" cols="30"></textarea>
            <div class="vjs-input__wrapper">
                <input type="text" class="mi-share-link" readonly="" value="">
            </div>
            <button type="button">COPY LINK</button>
        </form>
    </div>
</div>
    </div>
</div><div class="embed-media-details"><p class="media-leadtext">Every pitcher begins as a starter, and right-hander Eddie Butler wants to resume starting with the Texas Rangers. They acquired him Friday in the Cole Hamels trade with the Chicago Cubs. </p><div class="mi-video-bylines video-attributions-5815159613001">By <span class="bylines"></span></div><p></p></div></div>
                                    
                                    
                                    
                                
                                    <br>
                                    
                                    
                                    
                                
                                    <br>
                                    
                                    
                                    
                                
                                    <p></p>
                                    
                                    
                                    
                                
                                    <p>3. Delino DeShields is back with the Rangers after three games at Round Rock following <a href="https://www.star-telegram.com/sports/mlb/texas-rangers/article215467145.html" target="_self">his Tuesday demotion</a>.<br><br></p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">The same was said then that was said Saturday: The Rangers needed a relief pitcher, and DeShields needed to a different environment to work on some things.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">The only way he could return before the minimum 10-day stay in the minors was if he was needed as an injury replacement, which he was after Ryan Rua hit the disabled list with back spasms.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Banister contends that the three days at Round Rock gave DeShields the opportunity to “unplug,” as he likes to call it. Most pulls from the socket happen at the big-league level, but DeShields had to go to the minors because of need in the bullpen.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">Rua, of course, could have gone and DeShields could have “unplugged” on the bench.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">The discussion in the pregame session with the manager was like the Who’s on First routine. It resulted in one reporter just throwing up his hands and saying he was confused, and he wasn’t alone.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">The DeShields demotion wasn’t billed as a short-term thing. On Tuesday it sounded like he was going down as Odor did in 2015. Yet, it was sold Saturday that three days was just what DeShields needed.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">He’s back now, though who knows what will happen later in the week when reliever Chris Martin can come off the DL or when right fielder Nomar Mazara is cleared to play.</p>
                                    
                                    
                                    
                                
                                    <p dir="ltr">With trades likely coming, perhaps that can save DeShields from another demotion. But it’s a messy situation that could have been avoided altogether.</p>
                                    
                                    
                                    
                                
                            
                            
                        </div>
                        <div class="hidden">
                            <div class="ad-widget" id="mn-gpt-8" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Large" Large="336x280" Medium="336x280" Small="336x280" Extra-Small="336x280" articleId="215705830"></div>
                        </div>
                        
                            
                                <!-- Nothing is configured -->
                            
                        
                            
                                <!-- Nothing is configured -->
                            
                        
                            
                                <!-- Nothing is configured -->
                            
                        

                        
                            
                            
                                
                                
                                
                                
                                    
                                
                                
                                    
                                
                                
                                

    


                            
                        
                    </div>
                </div>
                
                
                    
                    
                

                
                
                    
                        


    <script type='text/template' id='zerg-template'> 
        <div id="vendor-stories-content">
            <h2 class='heading vendor-storiescontent-heading'>Suggested for you</h2>
        </div>
        <div class="vendor-storiescontent-main-container" id="zergnet-widget-53330"></div>
     </script><div id='zerg-target'></div><script> lazyLoadingModule("zerg-template", "zerg-target", "zerg",500,
        undefined, undefined, "53330", undefined , undefined ); </script>

                    
                

               

                
                
                    <div id="commenting-container" class="commenting-container element-spacing-large">
                        <h2 class="heading link">
    <a class="comments-toggle" href="javascript:void(0);">
        <span class="glyphicon glyphicon-comment-o"></span>&nbsp; Comments &nbsp;<span class="glyphicon glyphicon-chevron-down rotate"></span>
    </a>
</h2>

<!--Needs to be on the DOM on page load for IE. Needs to be visible to set the correct height of the comment component. I'm hiding it on document ready. Appending it later did not work-->
<div id="fb-comments" class="fb-comments in" data-href="" data-width="100%" data-numposts="10"></div>

<script>
    jQuery(document).ready(function () {
        mi.commentingFaceboook.init();
    });
</script>

                    </div>
                
            </div>
            <div id="nativoArticlePage"></div>
        </div>
        


<div class="narrow-rail">
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-9" adtype="default" pkg="b" data-ad-policy="onPageLoad" audience="all" atf="y" defaultsize="Large" Large="Flex Ad" Medium="Flex Ad" Small="300x250" Extra-Small="None" articleId="215705830"></div>
    </div>
    <div class="element-spacing-medium">
        <div id="video-widget" class="headline-list">
            <h2 class="heading link"><a href="/video/">Videos</a></h2>
            <div class="teaser">
                <div id="container-" class="container-">
                    
                        




<div class="wf-wps-side-bar mi-video-sidebar-widget">
    <div class="vjs-sidebar-player-wrap">
        <div id="video-detail-215553810-1532834546630" class="media-wrap ">
    <div id="playerWrap-215553810-1532834546630" class="video-media vjs-wrapper">
        <video id="player-215553810-1532834546630"
               class="video-js vjs-16-9 mi-videojs brightcoveEnabled"
               data-url="https://www.star-telegram.com/sports/mlb/texas-rangers/article215553810.html"
               data-title="Rangers Jeff Banister on Khris Davis: He feels comfortable in the box against us"
               data-video-id="5813928811001"
               data-account="5615998025001"
               data-key="BCpkADawqM2rwsIfO8wUl9c9hB38MbOjlZotXHej_azhC4fpzDrgG_yDynchxYvWK82c6Tp7UrVLjnutTT3oczSjC6E62MdY8OIcX-N2LCEzzcGijSEWAcTMcilqgeTcauuTaCLWXjJ9Qwae"
               data-publication="star-telegram"
               data-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;description_url=https%3A%2F%2Fwww.star-telegram.com%2Fsports%2Fmlb%2Ftexas-rangers%2Farticle215553810.html&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;iu=%2F7675%2FFTW.site_star-telegram%2FSports%2FBaseball%2FPro&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;hl=en&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vid_t=Rangers%20Jeff%20Banister%20on%20Khris%20Davis%3A%20He%20feels%20comfortable%20in%20the%20box%20against%20us&amp;vpa=0&amp;vpmute=0&amp;adtest=false&amp;ciu_szs=300x250&amp;cmsid=2475993&amp;vid=5813928811001&amp;cust_params=sect%3DTexas%20Rangers"
               data-asset-type="video"
               data-video-auto-play="false"
               data-video-type="sidebar"
               crossOrigin="anonymous">
               </video>
        <div class="vjs-share">
    <button class="vjs-share-trigger">
        <span class="vjs-share-text">SHARE</span>
        <span class="vjs-share-icon glyphicon glyphicon-share"></span>
    </button>
</div>
<div class="vjs-overlay">
    <div class="vjs-overlay__sharing video-share-icons">
        <a href="" target="blank" class="vjs-overlay-sharing_item facebook-share glyphicon glyphicon-facebook"></a>
        <a href="" target="blank" class="vjs-overlay-sharing_item twitter-share glyphicon glyphicon-twitter"></a>
        <a href="mailto:?&subject=&body=" target="blank" class="vjs-overlay-sharing_item email-share glyphicon glyphicon-envelope"></a>
        <a href="#" class="vjs-overlay-sharing_item glyphicon glyphicon-code vjs-overlay-sharing__embed"></a>
        <form class="vjs-sharing__link">
            <textarea class="overlay-embed-share" cols="30"></textarea>
            <div class="vjs-input__wrapper">
                <input type="text" class="mi-share-link" readonly value="">
            </div>
            <button type="button">COPY LINK</button>
        </form>
    </div>
</div>
    </div>
</div>

        <h4 class="title video-title"><a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215553810.html">Rangers Jeff Banister on Khris Davis: He feels comfortable in the box against us</a></h4>
    </div>
    <div class="vjs-sidebar-player-wrap">
        <div id="video-detail-215411160-1532834546630" class="media-wrap ">
    <div id="playerWrap-215411160-1532834546630" class="video-media vjs-wrapper">
        <video id="player-215411160-1532834546630"
               class="video-js vjs-16-9 mi-videojs brightcoveEnabled"
               data-url="https://www.star-telegram.com/sports/mlb/texas-rangers/article215411160.html"
               data-title="Cole Hamels says current woes are ‘worst of my career’"
               data-video-id="5813020493001"
               data-account="5615998025001"
               data-key="BCpkADawqM2rwsIfO8wUl9c9hB38MbOjlZotXHej_azhC4fpzDrgG_yDynchxYvWK82c6Tp7UrVLjnutTT3oczSjC6E62MdY8OIcX-N2LCEzzcGijSEWAcTMcilqgeTcauuTaCLWXjJ9Qwae"
               data-publication="star-telegram"
               data-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;description_url=https%3A%2F%2Fwww.star-telegram.com%2Fsports%2Fmlb%2Ftexas-rangers%2Farticle215411160.html&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;iu=%2F7675%2FFTW.site_star-telegram%2FSports%2FBaseball%2FPro&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;hl=en&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vid_t=Cole%20Hamels%20says%20current%20woes%20are%20%E2%80%98worst%20of%20my%20career%E2%80%99&amp;vpa=0&amp;vpmute=0&amp;adtest=false&amp;ciu_szs=300x250&amp;cmsid=2475993&amp;vid=5813020493001&amp;cust_params=sect%3DTexas%20Rangers"
               data-asset-type="video"
               data-video-auto-play="false"
               data-video-type="sidebar"
               crossOrigin="anonymous">
               </video>
        <div class="vjs-share">
    <button class="vjs-share-trigger">
        <span class="vjs-share-text">SHARE</span>
        <span class="vjs-share-icon glyphicon glyphicon-share"></span>
    </button>
</div>
<div class="vjs-overlay">
    <div class="vjs-overlay__sharing video-share-icons">
        <a href="" target="blank" class="vjs-overlay-sharing_item facebook-share glyphicon glyphicon-facebook"></a>
        <a href="" target="blank" class="vjs-overlay-sharing_item twitter-share glyphicon glyphicon-twitter"></a>
        <a href="mailto:?&subject=&body=" target="blank" class="vjs-overlay-sharing_item email-share glyphicon glyphicon-envelope"></a>
        <a href="#" class="vjs-overlay-sharing_item glyphicon glyphicon-code vjs-overlay-sharing__embed"></a>
        <form class="vjs-sharing__link">
            <textarea class="overlay-embed-share" cols="30"></textarea>
            <div class="vjs-input__wrapper">
                <input type="text" class="mi-share-link" readonly value="">
            </div>
            <button type="button">COPY LINK</button>
        </form>
    </div>
</div>
    </div>
</div>

        <h4 class="title video-title"><a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215411160.html">Cole Hamels says current woes are ‘worst of my career’</a></h4>
    </div>
</div>

                    
                </div>
                <div class="clearfix footer element_spacing_large">
                    <p class="readmore pull-left">
                        <a href="/video">
                            View More Video
                        </a>
                    </p>
                </div>
            </div>
        </div>
    </div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-10" adtype="default" pkg="c" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Large" Large="300x250" Medium="300x250" Small="300x250" Extra-Small="None" articleId="215705830"></div>
    </div>
    
        
            
    <div id="market-widget-1" class="element-spacing-medium">
        <!--   updated 5/5/17 and then reverted 5/8/17 kparker to change the file used for the featured_ads.json.  For a while, AP was sending invalid url in the xml.  But they fixed it so now this widget is back to the way it was.  
  update 6/26/18 to change script src to https protocol -->
<script src="https://media.star-telegram.com/static/scripts/classad_widget/MI_ClassAd_Widget.js"></script>
<script>
jQuery("document").ready(function (){
	mi.classadwidget = new mi.ClassAd_Widget({
		jsonURL : "https://media.star-telegram.com/static/scripts/classad_widget/featured_ads.json",
		targetElement : "#classified-featured-ads",
		setSize: 5,
		classad_url: "http://classifieds.star-telegram.com/detail/"
	});
});
</script>
<div id="classified-featured-ads" class="revenue-item headline-list element_spacing_large">
<h2>Local Spotlight</h2>
</div>
    </div>

        
    
    
    


<div class="element-spacing-medium">
    <section id="more-stories-widget" class="headline-list element_spacing_large">
        
            
                <h2 class="heading link">
                    <a href="/sports/mlb/texas-rangers/">
                        Texas Rangers
                    </a>
                </h2>
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215705825.html">
                                        Here’s what newest Rangers pitcher hopes to do after trade from Cubs
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215714150.html">
                                        Beltre’s deadline conflict: Win elsewhere vs. loyalty to Rangers
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215705725.html">
                                        Kela receiving most interest as Rangers approach Tuesday’s deadline
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215690895.html">
                                        Rangers Reaction: Hamels trade in ’15 a success. How does trade to Cubs look?
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/sports/mlb/texas-rangers/article215680455.html">
                                        Rangers remain open to trades. Who could be next to go?
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                <div class="clearfix">
                    <div class="more-stories-link wps-stories-link">
                        <a href="/sports/mlb/texas-rangers/">
                            Texas Rangers
                        </a>
                    </div>
                </div>
            
        
            
        
    </section>
</div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-11" adtype="default" pkg="e" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Large" Large="Flex Ad" Medium="Flex Ad" Small="300x250" Extra-Small="None" articleId="215705830"></div>
    </div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-12" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="nonsub" atf="n" defaultsize="Large" Large="300x250" Medium="300x250" Small="300x250" Extra-Small="None" oom="y"  articleId="215705830"></div>
    </div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-13" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="nonsub" atf="n" defaultsize="Large" Large="300x250" Medium="300x250" Small="300x250" Extra-Small="None" oom="y"  articleId="215705830"></div>
    </div>
</div>

    </div>
</section>

<div class="container">
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-14" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Large" Large="728x90" Medium="728x90" Small="728x90" Extra-Small="none" articleId="215705830"></div>
    </div>
</div>

    <img src="https://cdn.relaymedia.com/ping?url=%2F%2Fwww.star-telegram.com%2Fsports%2Fmlb%2Ftexas-rangers%2Farticle215705830.html" width="1" height="1">

<script type="text/javascript">
    jQuery(document).ready(function () {
        UD.updateDate.getDiffDate("1532834494", "MMMM DD, YYYY hh:mm A", "America/Chicago", "en", "-05:00");
    });
</script>
    

        
    
        
<div id="footer" class="wps-footer">
    <header id="footer-logo">
        <div class="container text-center">
            <a href="/" target="_top">
                <img src="/wps/build/images/star-telegram/logo-sm.png" alt="Fort Worth Star Telegram | Star-Telegram.com" class="img-responsive" />
            </a>
        </div>
    </header>
    <div class="container">
        <div class="row">
            <div id="accordion" class="panel-group">
                <div class="panel full-width-content col-sm-6 col-md-6">
                    <div class="panel-heading">
                        <h2 class="heading"><a data-toggle="" data-parent="#accordion" href="#collapseOne">Subscriptions</a></h2>
                    </div>
                    <div id="collapseOne" class="panel-collapse collapse in">
                        <div class="panel-body">
                            <ul class="footer-menu">
                                
                                    <li><a href="https://account.star-telegram.com/static/subscribe/#navlink=mi_footer">Start a Subscription</a></li>
                                
                                    <li><a href="https://mcciservices.newscyclecloud.com/cgi-bin/cmo_mcc-c-cmdb-cst-01.sh/custservice/web/login.html?siteid=FTW#navlink=mi_footer">Customer Service</a></li>
                                
                                    <li><a href="http://digital.olivesoftware.com/Olive/ODN/FortWorth/#navlink=mi_footer">eEdition</a></li>
                                
                                    <li><a href="https://mcciservices.newscyclecloud.com/cgi-bin/cmo_mcc-c-cmdb-cst-01.sh/custservice/web/login.html?siteid=FTW#navlink=mi_footer">Vacation Hold</a></li>
                                
                                    <li><a href="https://mcciservices.newscyclecloud.com/cgi-bin/cmo_mcc-c-cmdb-cst-01.sh/custservice/web/login.html?siteid=FTW#navlink=mi_footer">Pay Your Bill</a></li>
                                
                                    <li><a href="/rewards">Rewards</a></li>
                                
                            </ul>
                        </div>
                    </div>
                </div>
                <div class="panel full-width-content col-sm-6 col-md-6">
                    <div class="panel-heading">
                        <h2 class="heading"><a data-toggle="" data-parent="#accordion" href="#collapseTwo">Site Information</a></h2>
                    </div>
                    <div id="collapseTwo" class="panel-collapse collapse in">
                        <div class="panel-body">
                            <ul class="footer-menu">
                                
                                    <li><a href="https://www.star-telegram.com/customer-service/about-us/#navlink=mi_footer">About Us</a></li>
                                
                                    <li><a href="https://www.star-telegram.com/customer-service/contact-us/#navlink=mi_footer">Contact Us</a></li>
                                
                                    <li><a href="http://x.email.star-telegram.com/ats/url.aspx?cr=663&amp;wu=12#navlink=mi_footer">Newsletters</a></li>
                                
                                    <li><a href="http://niestar-telegram.com/#navlink=mi_footer">News in Education</a></li>
                                
                            </ul>
                        </div>
                    </div>
                </div>
                <div class="panel full-width-content col-sm-6 col-md-6">
                    <div class="panel-heading">
                        <h2 class="heading"><a data-toggle="" data-parent="#accordion" href="#collapseThree">Social, Mobile &amp; More</a></h2>
                    </div>
                    <div id="collapseThree" class="panel-collapse collapse in">
                        <div class="panel-body">
                            <ul class="footer-menu">
                                
                                    <li><a href="http://x.email.star-telegram.com/ats/url.aspx?cr=663&amp;wu=49#navlink=mi_footer">Text News Alerts</a></li>
                                
                                    <li><a href="/mobile/#navlink=mi_footer">Mobile &amp; Apps</a></li>
                                
                                    <li><a href="https://www.facebook.com/startelegram">Facebook</a></li>
                                
                                    <li><a href="https://twitter.com/startelegram">Twitter</a></li>
                                
                                    <li><a href="https://www.youtube.com/user/startelegramvideo">YouTube</a></li>
                                
                                    <li><a href="https://google.com/+startelegram">Google+</a></li>
                                
                                    <li><a href="http://x.email.star-telegram.com/ats/url.aspx?cr=663&amp;wu=12#navlink=mi_footer">Newsletters</a></li>
                                
                            </ul>
                        </div>
                    </div>
                </div>
                <div class="panel full-width-content col-sm-6 col-md-6">
                    <div class="panel-heading">
                        <h2 class="heading"><a data-toggle="" data-parent="#accordion" href="#collapseFour">Advertising</a></h2>
                    </div>
                    <div id="collapseFour" class="panel-collapse collapse in">
                        <div class="panel-body">
                            <ul class="footer-menu">
                                
                                    <li><a href="/advertise/#navlink=mi_footer#navlink=mi_footer">Information</a></li>
                                
                                    <li><a href="http://fortworthstartelegram.adperfect.com/">Place a Classified</a></li>
                                
                                    <li><a href="http://findnsave.star-telegram.com/#navlink=mi_footer">Shopping</a></li>
                                
                            </ul>
                        </div>
                    </div>
                </div>
            </div>
        </div>
        <div class="row" id="footer-legal">
            <div class="panel col-sm-6 col-md-3 full-width-content">
                <div class="panel-heading">
                    <h2 class="heading"><a data-toggle="" data-parent="#footer-legal" href="#collapseLegal">More</a></h2>
                </div>
                <div id="collapseLegal" class="panel-collapse collapse in">
                    <div class="panel-body">
                        <ul class="footer-menu-legal">
                            
                                <li><a href="/customer-service/copyright/#navlinks=mi_footer">Copyright</a></li>
                            
                                <li><a href="/customer-service/commenting-policy/#navlinks=mi_footer">Commenting Policy</a></li>
                            
                                <li><a href="/customer-service/privacy-policy/#navlink=mi_footer">Privacy Policy</a></li>
                            
                                <li><a href="/customer-service/terms-of-service/#navlink=mi_footer">Terms of Service</a></li>
                            
                        </ul>
                    </div>
                </div>
            </div>
        </div>
    </div>
</div>


<script type="text/javascript">
  jQuery(document).ready(function () {
    mi.footer.init();
  });
</script>
       
    <div id="wallpaperWrapper" style="display:inline;">
        <div class="ad-widget" id="mn-gpt-15" adtype="wallpaper" pkg="None" data-ad-policy="onPageLoad" audience="all" atf="y" defaultsize="Large" Large="1600x600" Medium="None" Small="None" Extra-Small="None" articleId="215705830"><script type='text/javascript'>initWallpaperAd(['#mn-gpt-15'], 'section[role="main"]'); createWallpaperAd();</script></div>
    </div>
      
          <div id="floorboard" class="hidden-xs">
              <div id="floorboard_outer">
                  <div id="floorTagWrapper" style="display:none;">
                      <div class="ad-widget" id="mn-gpt-16" adtype="floorboard" pkg="a" data-ad-policy="onPageLoad" audience="all" atf="n" defaultsize="Large" Large="285x70" Medium="285x70" Small="285x70" Extra-Small="None" articleId="215705830"></div>
                  </div>
              </div>
          </div>
      
    
    
        <script type="text/javascript">
        var optimeraEnabled = false;
            optimeraEnabled = true;
            var oDv = [];
            var oVa = {};
            mi_OptimeraTools.init('11');
            //Do not edit
            (function() {
                var optimeraHost = window.location.host;
                var optimeraPathName = window.location.pathname;
                var optimeraScript = document.createElement('script');
                optimeraScript.async = true;
                optimeraScript.type = 'text/javascript';
                rand = Math.random();
                optimeraScript.src="https://s3.amazonaws.com/elasticbeanstalk-us-east-1-397719490216/json/client/"+oDv[0]+"/"+optimeraHost+optimeraPathName+".js?t="+rand;
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(optimeraScript, node);
                var optimeraOpsScript = document.createElement('script');
                optimeraOpsScript.async = true;
                optimeraOpsScript.type = 'text/javascript';
                optimeraOpsScript.src="https://s3.amazonaws.com/elasticbeanstalk-us-east-1-397719490216/external_json/oPS.js";
                document.head.appendChild(optimeraOpsScript);
                var s = +new Date;
                while (+new Date < s + 200) {/*Default 200ms Timeout*/};
            })();

            mi_Ads.env.create();
        mi_Ads.env.init();
        </script>
    
  

<div id="mistatstag" style="display:none;">
    
        <script src="//media.star-telegram.com/mistats/products/escenic_s_code.js"></script>
        <script src="//media.star-telegram.com/mistats/products/escenic.js"></script>
        <script src="//media.star-telegram.com/mistats/finalizestats.js"></script>
    
</div>


   














    
    
    
    
    
    
    
    

    
        
    

<script type="text/javascript">
    //<![CDATA[
    var clientDT = new Date().getTime();
    document.write('<img style="display:none;" src="https://ece-logger.nandomedia.com/analysis-logger/Logger?rt=1&ctxId=6132&contextPath=3187-6132&pubId=11&cat=&meta=read-story&objId=215705830&type=article&title=Rangers+Reaction%3A+The+hits+keeps+coming+for+Odor%2C+thanks+to+recapturing+his+edge&url=%2F%2Fwww.star-telegram.com%2Fsports%2Fmlb%2Ftexas-rangers%2Farticle215705830.html&amp;clientDT=' + clientDT + '" alt="" width="1" height="1"/>');
    //]]>
</script>

<noscript>
    <div>
        <img src="https://ece-logger.nandomedia.com/analysis-logger/Logger?rt=1&ctxId=6132&contextPath=3187-6132&pubId=11&cat=&meta=read-story&objId=215705830&type=article&title=Rangers+Reaction%3A+The+hits+keeps+coming+for+Odor%2C+thanks+to+recapturing+his+edge&url=%2F%2Fwww.star-telegram.com%2Fsports%2Fmlb%2Ftexas-rangers%2Farticle215705830.html" alt="one pixel graphics" width="1" height="1"/>
    </div>
</noscript>




    

        
    




<div class="overlay overlay-data">
    <div id="overlayParent">
        <div class="overlayHeading">
            <h3 class="title"></h3>
             
            <div class="arrow-box"></div>
        </div>
        


       
    </div>
    
    <div id="backToStory">
        <a class="backLink" href="//www.star-telegram.com/sports/mlb/texas-rangers/article215705830.html">
            <span class="fa glyphicon-long-arrow-left"></span>
            <span class="back-label">Back to story</span>
        </a>
    </div>
</div>


        
        
    
<script type="text/javascript">
    var WFClientTypeDef = {
        "extraSmall": "(max-width: 767px)",
        "medium": "(min-width: 992px) and (max-width: 1199px)",
        "large": "(min-width: 1200px)",
        "small": "(min-width: 768px) and (max-width: 991px)"
    };
    var imageSizes = [80, 160, 200, 320, 400, 480, 560, 640, 720, 768, 960, 1080, 1140];
</script>
<script type="text/javascript" src="/wps/build/js/mi-footer-5818ee789d.js"></script>

<script src="//imasdk.googleapis.com/js/sdkloader/ima3.js" type="text/javascript"></script>

    <script src="https://ovp.iris.tv/libs/adaptive/v2/iris.adaptive.js" type="text/javascript"></script>
    <script type="text/javascript" src="/wps/build/webpack/brightcoveVideo.bundle-297cf876af2ad54d4105.js"></script>



    <script type="text/javascript">
        /* <![CDATA[ */
        var google_conversion_id = 968074018;
        var google_custom_params = window.google_tag_params;
        var google_remarketing_only = true;
        /* ]]> */
    </script>
    <script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
    </script>
    <noscript>
        <div style="display:inline;">
            <img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/968074018/?value=0&guid=ON&script=0"/>
        </div>
    </noscript>




    <script type="text/javascript">
        mi.pageInfo.setConf("chartbeat.uid", 62447);
    </script>

<script src="/wps/source/scripts/libs/md5.min.js"></script>
<script type="text/javascript">
    var nextbee = {
        user_cookie: undefined,
        user_email: undefined,
        nextbee_host: "app.nextbee.com",
        nextbee_campaign: "3728",
        nextbee_client: "1703",
        API_AUTHORIZATION_KEY: 'DECGCFCFHEACGCDBIBGZ158469415068700193Y!n-868654787',
        ENCRYPTION_KEY: '0.9240762',

        credit_read_story: function() {
            this.post_to_nextbee("5439");
        },

        credit_watch_video: function() {
            this.post_to_nextbee("5248");
        },

        credit_share_articles: function(id, url) {
            this.post_to_nextbee(id, url);
        },

        initialize: function() {
            this.user_cookie = checkUserSubscribed('MPPUser');
            if (this.user_cookie) {
                var cookie_json = JSON.parse(this.user_cookie);
                if (cookie_json) {
                    this.user_email = cookie_json.NextBeeEmail;
                }
            }
            
                this.credit_read_story();
            
        },

        required_values_present: function (widget_id) {
            return this.user_cookie && this.user_email &&
                   this.nextbee_host && this.nextbee_client && this.nextbee_campaign &&
                   widget_id;
        },

        post_to_nextbee: function (widget_id, href) {
            if (this.required_values_present(widget_id)) {
                var nextbee_url = ['https://' + this.nextbee_host, 'nextbeeapis',
                    this.nextbee_client, this.nextbee_campaign, 'Event'].join('/') +
                    '?email=' + encodeURIComponent(this.user_email) +
                    '&widget_config_id=' + widget_id;
                var timestamp_key = Math.floor(Date.now()).toString();
                var api_call_signature = md5(this.API_AUTHORIZATION_KEY +
                    this.ENCRYPTION_KEY + timestamp_key);

                console.log("NextBee URL: " + nextbee_url +
                    "\nAuth. Key: " + this.API_AUTHORIZATION_KEY +
                    "\nEnc. Key:  " + this.ENCRYPTION_KEY +
                    "\nTimestamp: " + timestamp_key +
                    "\nSignature: " + api_call_signature);

                $.ajax( { url: nextbee_url, type: 'post', headers: {
                    'ts-key': timestamp_key,
                    'api-call-signature': api_call_signature,
                    'cache-control': 'no-cache',
                    'content-type': 'application/json',
                    },
                    complete: function(data) {
                        if(href)
                        {
                            window.location.href = href;
                        }
                        console.log("NextBee API response: " + data.responseText);
                    }
                } );
            }
        }
    };

    $(function(){
        nextbee.initialize();
    });
</script>



<!-- Start Lotame Tag -->
    <script src="//tags.crwdcntrl.net/c/7450/cc.js?ns=_cc7450" id="LOTCC_7450"></script>
    <script>_cc7450.bcp();</script>
<!-- End Lotame Tag -->




    </body>
</html>
