<!DOCTYPE html>
<html lang="en">
    <head>
        
    <meta charset="utf-8">

    
    


        
    
        
    <script>
    var gomez={
    gs: new Date().getTime(),
    acctId:"D3FD89",
    grpId:"Escenic",
    grpId1:"FTW",
    grpId2:window.location.hostname,
    grpId3:"unknown",
    pgId:"story-detail",
    wrate:1
};
</script>




    
        <meta name="msapplication-TileColor" content="#FFFFFF"/>
    

    
        <meta name="msapplication-TileImage" content="https://www.star-telegram.com/wps/source/images/star-telegram/windowsmetro-144.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-144-precomposed.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-114-precomposed.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-72-precomposed.png"/>
    

    
        <link rel="apple-touch-icon-precomposed" href="https://www.star-telegram.com/wps/source/images/star-telegram/apple-touch-icon-57-precomposed.png"/>
    

    
        <link rel="shortcut icon" href="https://www.star-telegram.com/wps/source/images/star-telegram/favicon.png"/>
    

    
        <meta name="twitter:card" content="summary_large_image"/>
    

    
        <meta name="twitter:site" content="startelegram"/>
    

    
        <meta name="twitter:title" content="Politician, ex-codebreaker Baroness Trumpington dies at 96"/>
    

    
        <meta property="og:site_name" content="star-telegram"/>
    

    
        <meta property="og:type" content="article"/>
    

    
        <meta property="og:title" content="Politician, ex-codebreaker Baroness Trumpington dies at 96"/>
    

    
        <meta property="og:url" content="https://www.star-telegram.com/news/nation-world/world/article222234035.html"/>
    

    
        <meta property="og:description" content="British socialite, codebreaker, politician and bon vivant Jean Barker _ better known by her title, Baroness Trumpington _ has died."/>
    

    
        <meta name="twitter:description" content="British socialite, codebreaker, politician and bon vivant Jean Barker _ better known by her title, Baroness Trumpington _ has died."/>
    

    
        <meta property="og:image" content="https://www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_1140/Britain_Obit_Codebreaking_Baroness_16899.jpg"/>
    

    
        <meta name="twitter:image" content="https://www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_1140/Britain_Obit_Codebreaking_Baroness_16899.jpg"/>
    

    
        <meta property="fb:app_id" content="155812681283151"/>
    

    

    
        <meta name="title" content="Politician, ex-codebreaker Baroness Trumpington dies at 96 | Fort Worth Star-Telegram"/>
    

    
        <meta name="allow-comments" content="true"/>
    

    
        <meta name="expires" content="Tue, 11 Dec 2018 13:35:56 UTC"/>
    

    
        <meta name="copyright" content="Copyright 2018 The Associated Press. All rights reserved. This material may not be published, broadcast, rewritten or redistributed."/>
    

    
        <meta name="description" content="British socialite, codebreaker, politician and bon vivant Jean Barker _ better known by her title, Baroness Trumpington _ has died."/>
    

    
        <meta name="keywords" content="EU, Britain, Obit, Codebreaking, Baroness"/>
    

    
        <meta name="news_keywords" content="EU, Britain, Obit, Codebreaking, Baroness"/>
    

    
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
    

    
        <meta name="googlebot" content="noodp, noarchive"/>
    

    
        <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
    

    
        <link rel="canonical" href=""/>
    

    
        <meta name="original-source" content=""/>
    

    
        <meta name="google-site-verification" content="zLQTVtfwr_FaFe6A7f-Yxjz2dhOn4VTFy87suqUWDLo"/>
    






<meta name="title" content="Politician, ex-codebreaker Baroness Trumpington dies at 96 | Fort Worth Star-Telegram">
<meta name="og:title" content="Politician, ex-codebreaker Baroness Trumpington dies at 96 | Fort Worth Star-Telegram">





    <meta property="article:content_tier" content="metered"/>


<title>Politician, ex-codebreaker Baroness Trumpington dies at 96 | Fort Worth Star-Telegram</title>

<link rel="amphtml" href="http://amp.star-telegram.com/news/nation-world/world/article222234035.html">

<meta name="msapplication-TileImage" content="/wps/build/images/star-telegram/windowsmetro-144.png"/>




        <meta property="fb:pages" content="17636558529" />




<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wps/build/images/star-telegram/apple-touch-icon-144-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wps/build/images/star-telegram/apple-touch-icon-114-precomposed.png">
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wps/build/images/star-telegram/apple-touch-icon-72-precomposed.png">
<link rel="apple-touch-icon-precomposed" href="/wps/build/images/star-telegram/apple-touch-icon-57-precomposed.png">
<link rel="shortcut icon" href="/wps/build/images/star-telegram/favicon.png">




<script type="text/javascript"
            src="/wps/source/scripts/libs/require.js"></script>

<script type="text/javascript">
    var wpsConfig = {
        baseUrl: '/wps/source/scripts/src',
        urlArgs: 'misv=07d2dbd',
        paths: {
            'moment': '../libs/moment.min',
            'identity': '../libs/identityModulev3.min'
        },
        waitSeconds: 0
    };
    
    var wpsRequire = requirejs.config(wpsConfig);

</script>

<script>
    var mi = (function(mod) {
        mod.lazyloaders = mod.lazyloaders || [];
        return mod;
    })(mi || {});

    var rtkcategories = ["News","World"];
</script>


    <script>mi.inMarket=false</script>





    <link href="/wps/build/css/theme.markets/star-telegram-43a3977285.css" rel="stylesheet" type="text/css"/>



<!--[if lt IE 9]>
<script type="text/javascript" src="//oss.maxcdn.com/html5shiv/3.7.3/html5shiv.min.js"></script>
<script type="text/javascript" src="//oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.9/es5-shim.min.js"></script>
<![endif]-->

<script type="text/javascript" src=" /wps/source/scripts/libs/jquery-1.10.2.min.js"></script>
<script type="text/javascript" src="/wps/build/js/mi-header-8c560c29fe.js"></script>



    <script type="text/javascript" src="/wps/source/scripts/libs/guid.js"></script>
    <script>
        wpsRequire(['identity'], function(IdentityModule) {
            $(window).load(function() {
                var identityCookieName = 'AccessToken';
                var accessTokenCookie = mi.getCookie(identityCookieName);
                
                if (!accessTokenCookie) {
                    var identityModule = new IdentityModule();
                    var identityPrefix = 'mcv4';
                    
                    $.getJSON('https://api.ipify.org?format=jsonp&callback=?')
                    .done(function(json) {
                        identityModule.GenerateIdentity(identityCookieName, identityPrefix, [json.ip]);
                    })
                    .fail(function() {
                        identityModule.GenerateIdentity(identityCookieName, identityPrefix, [getGuid()]);
                    });
                }
            });
        });
    </script>
    
        


        <!-- 
                
                
                
                
                

                
                
                
                

                
                
                

                
                

                
                
                
                
                
                
                

                
                
                
                

                
                
                
                


                
                    
                        
                        
                    

                
                

                
                    
                

                
                
                 -->


    



<script type="text/javascript">
mi.pageInfo.setConf({
'marketInfo.viewsizes':[{"Extra-Small":[0,0]},{"Large":[1200,600]},{"Medium":[992,300]},{"Small":[768,300]}],
'marketInfo.adsizes':{"outofpage":{},"wallpaper":{'1600x600':[1600,600],'None':[]},"floorboard":{'285x70':[285,70],'None':[]},"default":{'120x20':[120,20],'120x240':[120,240],'120x600':[120,600],'146x60':[146,60],'160x600':[160,600],'160x90':[160,90],'168x28':[168,28],'180x150':[180,150],'216x36':[216,36],'234x60':[234,60],'240x400':[240,400],'300x100':[300,100],'300x250':[300,250],'300x50':[300,50],'300x600':[300,600],'300x75':[300,75],'320x450':[320,450],'320x50':[320,50],'336x280':[336,280],'468x60':[468,60],'500x300':[500,300],'600x250':[600,250],'728x90':[728,90],'960x30':[960,30],'970x90':[970,90],'Billboard Flex':[[960,30],[970,90],[728,90],[970,250]],'Billboard Flex2':[[970,90],[970,250]],'Billboard Flex3':[[970,90],[970,250],[728,90]],'Flex Ad':[[300,250],[300,600]],'None':[],'Rising Star':[500,300],'Welcome Ad':[[300,250],[300,600],[550,480],[600,500]]} },'accuweather.apiKey':'2ce96fe9da724185a27db1e6a3ecf580',
'accuweather.dev':'false',
'accuweather.locationKey':'351196',
'accuweather.locationString':'Fort Worth',
'accuweather.partnerCode':'MCCLATCHY',
'cs.circ_phone':'800-776-7827 (STAR)',
'cs.circ_url':'http://www.star-telegram.com/myaccount',
'facebook.app.id':'155812681283151',
'financialContent.account':'startelegram',
'findnsave.tracking':'findnsave',
'headerDateDisplay':'false',
'legacy.affiliateId':'df000321',
'legacy.siteName':'dfw',
'marketInfo.CarsAFF':'ftworth',
'marketInfo.CarsSEO':'',
'marketInfo.JobsQSCTY':'Fort Worth',
'marketInfo.JobsQSSTS':'TX,US',
'marketInfo.JobsSEO':'',
'marketInfo.JobsSiteID':'cbcb_fwst',
'marketInfo.Jobslr':'CBCB_FWST',
'marketInfo.LiveConnectTag':'a-01ei',
'marketInfo.addcities':'Dallas, Arlington, Irving ',
'marketInfo.adretargeting.kill_list':'[&quot;simpli.fi&quot;]',
'marketInfo.allow_ads':'true',
'marketInfo.allow_nativo':'true',
'marketInfo.careerbuilder.lr':'CBCB_FWST',
'marketInfo.careerbuilder.mxjobsrchcriteria_rawwords':'outside+sales',
'marketInfo.careerbuilder.s_freshness':'30',
'marketInfo.careerbuilder.s_rawwords':'CustomField3:FTWORTHTJ',
'marketInfo.city':'Fort Worth',
'marketInfo.clipped_taxonomy':'News/World',
'marketInfo.code':'FTW',
'marketInfo.county':'Tarrant County',
'marketInfo.domain':'star-telegram',
'marketInfo.followLinks':'true',
'marketInfo.kill_dealsaver':'true',
'marketInfo.location':'Fort Worth',
'marketInfo.market_identifier':'FTW.site_star-telegram',
'marketInfo.name':'Fort Worth Star Telegram',
'marketInfo.networkid':'7675',
'marketInfo.phone':'800-776-7827',
'marketInfo.product':'site',
'marketInfo.region':'Southwest',
'marketInfo.siteId':'58',
'marketInfo.sourcelevel':'world',
'marketInfo.state':'Texas',
'marketInfo.state_abbreviation':'TX',
'marketInfo.staticDirectory':'star-telegram',
'marketInfo.street_address':'808 Throckmorton St., Fort Worth, TX 76102',
'marketInfo.taxonomy':'News/World///',
'marketInfo.webmaster_email':'online@star-telegram.com',
'marketInfo.zipcode':'76102',
'nativo.story.placements':'840666,748348,844387',
'nativo.video.placements':'869310,869309',
'obituaries.deathNoticeEmail':'obits@star-telegram.com',
'obituaries.deathNoticePhone':'817-390-7780',
'obituaries.deathNoticeUrl':'http://www.legacy.com/obituaries/dfw/obituary-place-an-obituary.aspx',
'pressPlus.zone':'De9IUjiwbtDoGVuBqaiiuC',
'publication.domain':'Star-Telegram.com',
'publication.mediadomain':'media.star-telegram.com',
'wishabi.bodyId':'834',
'wishabi.navId':'1482',
'wufoo.formID':'',
'marketInfo.pagelevel':'story',
});
</script>

<script type="text/javascript">
    var mistats = mistats || {};
    mistats.pagelevel="Story";
    mistats.cmsid="Story:222234035";
    mistats.pagename="Story:222234035|Politician, ex-codebreaker Baroness Trumpington dies at 96";
    mistats.taxonomy="News|World|||";
    mistats.channel="World";
    mistats.contentsource="The_Associated_Press|By JILL LAWLESS Associated Press";
    mistats.pubdate="2018/11/27";
    mistats.moddate="2018/11/27 H07";
    mistats.keywords="EU Britain Obit Codebreaking Baroness";
</script>


<script src="//media.star-telegram.com/misites/dfw/star-telegram.js"></script>


    <script type="text/javascript">
        var imgLazyLoadThreshold = 500;
    </script>



    
        
    <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [],
        googletag.cmd.push(function(){
            googletag.pubads().disableInitialLoad();
        });
        var getPreBidVarValue = function() {
            var constructedVar;
            var urlPathReg = /([^\/]*)\/*$/;
            var classifiedSearchReg = /homes|cars|jobs|search/;
            var urlPath = window.location.pathname;
            var lastUrlComponent = urlPath.match(urlPathReg)[1];
            var marketIdentifier = mi.pageInfo.getConf('marketInfo.market_identifier');
            var pageLevel = mi.pageInfo.getConf('marketInfo.pagelevel');
            var sourceLevel = mi.pageInfo.getConf('marketInfo.sourcelevel');
            var isArticle = new RegExp(/.html$/).test(urlPath);
            if ( lastUrlComponent === 'video' ) {
                pageLevel = 'videofront';
            } else if ( lastUrlComponent === 'galleries' ) {
                pageLevel = 'galleryfront';
            } else if ( lastUrlComponent.match(classifiedSearchReg) ) {
                pageLevel = pageLevel + '.' + sourceLevel;
            } else if (urlPath.search("/weather/") !== -1  && !isArticle) {
                pageLevel = 'sectfront.weather';
            } else if (urlPath.search("/latest-news/") !== -1 && !isArticle) {
                pageLevel = 'sectfront.latestnews';
            } else if (urlPath.search("-columns-blogs/") !== -1 && !isArticle) {
                pageLevel = 'blogfront';
            } else if (urlPath.search("/topics/") !== -1  && !isArticle) {
                pageLevel = 'sectfront';
            }
            if ( mi_Ads.env.outOfMarket.pageLevelOOM === true && mi_Ads.env.outOfMarket.serverOOMHeader === true ) {
                pageLevel = pageLevel + '-oom';
            }

            constructedVar = marketIdentifier + '.' + pageLevel;

            return constructedVar;
        };
        var preBidMarketPage = getPreBidVarValue();
    </script>
    <script src="//acdn.adnxs.com/prebid/c/7543_midwest1/pb.js" async="true"></script>

    
    
    
    <script type="text/javascript" src="//ad.crwdcntrl.net/5/c=7436/pe=y/callback=extractPid"></script>




<script type="text/javascript">
    var getSubscribedFlag = false;
</script>


    
        
    
    <script type="text/javascript">
        getSubscribedFlag = checkUserSubscribed('MPPSessionId');
    </script>






    








  
  



  







<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",

  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "//www.star-telegram.com/news/nation-world/world/article222234035.html"
  },

  
  "headline": "Politician, ex-codebreaker Baroness Trumpington dies at 96",
  "image": "https://www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/FREE_1140/Britain_Obit_Codebreaking_Baroness_16899.jpg",
  "datePublished": "2018/11/27",
  "dateModified": "2018/11/27 H07",
      "author": {
        "@type": "Person",
        "name": "By JILL LAWLESS  Associated Press "
      },
    "publisher": {
     "name": "Fort Worth Star-Telegram",
     "@type": "Organization",
     "logo": {
        "@type": "ImageObject",
        "url": "http://www.star-telegram.com/wps/build/images/star-telegram/amp-logo.png"
     }
  },
  
  "isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name": "star-telegram",
    "productID": "star-telegram.com:AllFTW-5008"
  },
  
  "description": "British socialite, codebreaker, politician and bon vivant Jean Barker _ better known by her title, Baroness Trumpington _ has died.",
  "isAccessibleForFree": "False",
  "hasPart":
    {
      "@type": "WebPageElement",
      "isAccessibleForFree": "False",
      "cssSelector" : ".paywalled"
    }
}
</script>



<script>
    var _prx = window._prx || [];
    _prx.push(['cfg.SetNoAutoStart']);
</script>
<script src="https://s.ntv.io/serve/load.js" async></script>




    <script src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5" async></script>





<script type="text/javascript">
    const newsletterSuccess = (form) => {
        const $div = document.createElement('div');

        $div.classList.add('success');
        $div.innerHTML = "Thanks for subscribing; you should start to receive your newsletter shortly.";
        document.querySelector('.grecaptcha-badge').remove();

        if(form.classList.contains('impact')){
            const $email = document.querySelector('.form-control');
            const $button = form.querySelector('.more-link-macro a');
            $email.parentNode.insertBefore($div, $email);
            form.querySelector('p').remove();
            $button.classList.add('success', 'disabled');
            $email.remove();
            $button.addEventListener('click', (e)=> {
                e.preventDefault();
                return false;
            });
        } else {
            form.innerHTML = '';
            form.appendChild($div);
        }
    };
    function callbackCaptcha(token){
        const $newsletterHomepage = document.querySelector('#newsletter .newsletter-cta-macro');
        const $newsletterSection = document.querySelector('#newsletter-signUpWidget');

        if($newsletterHomepage) {
            onSubmit($newsletterHomepage, token);
        }
        if($newsletterSection) {
            onSubmit($newsletterSection, token);
        }
    }
    function onSubmit(form, token){
        const data = JSON.parse(form.getAttribute('data-json'));

        data.captchaToken = token;
        form.removeAttribute('data-json');
        $.ajax({
            method: "POST",
            dataType: 'json',
            url: "https://api.mcclatchy.com/cheetahkit-api/recipient",
            data: data
        }).done(function (msg) {
            newsletterSuccess(form);
        }).fail(function (jqXHR, textStatus, errorThrown) {
            newsletterSuccess(form);
        });
    }
</script>
<script src='https://www.google.com/recaptcha/api.js' async defer></script>

    </head>

    

    

    
    
    
    

    <body class="wirestory wps-body-main  paywalled">
        
    
        






    
    <link href="/wps/build/css/refresh2018/stand-alone/mastheadFooter2018-8f5d6ea82b.css" rel="stylesheet" type="text/css"/>
    



<!-- WPS new Masthead -->
<header class="masthead short" role="banner">
<div class="hidden">
        <div class="ad-widget" id="mn-gpt-1" adtype="outofpage" pkg="None" data-ad-policy="onPageLoad" audience="all" vl=0 articleId="222234035"></div>
    </div>
<div class="masthead-top" role="menu">
        <div class="left">
            <div class="squeezable">
                <button id="sectionsmenu" class="labeled-menu" aria-haspopup="true" role="menuitem" >
                    <svg class="icon" width="18" height="18" aria-hidden="true" viewBox="0 0 1792 1792"><path d="M1664 1344v128q0 26-19 45t-45 19h-1408q-26 0-45-19t-19-45v-128q0-26 19-45t45-19h1408q26 0 45 19t19 45zm0-512v128q0 26-19 45t-45 19h-1408q-26 0-45-19t-19-45v-128q0-26 19-45t45-19h1408q26 0 45 19t19 45zm0-512v128q0 26-19 45t-45 19h-1408q-26 0-45-19t-19-45v-128q0-26 19-45t45-19h1408q26 0 45 19t19 45z"></path></svg>
                    <span>SECTIONS</span>
                </button>

                <a href="http://digital.olivesoftware.com/Olive/ODN/FortWorth/" class="mh-hide-sm" role="menuitem">
                    <svg class="icon ereader-button" aria-hidden="true" width="24" height="18" viewBox="0 2 2048 1792" style="margin-top: 2px;"><path d="M1024 512h-384v384h384v-384zm128 640v128h-640v-128h640zm0-768v640h-640v-640h640zm640 768v128h-512v-128h512zm0-256v128h-512v-128h512zm0-256v128h-512v-128h512zm0-256v128h-512v-128h512zm-1536 960v-960h-128v960q0 26 19 45t45 19 45-19 19-45zm1664 0v-1088h-1536v1088q0 33-11 64h1483q26 0 45-19t19-45zm128-1216v1216q0 80-56 136t-136 56h-1664q-80 0-136-56t-56-136v-1088h256v-128h1792z"></path></svg>
                </a>

                <a href="/weather" class="mh-hide-sm" role="menuitem">
                    <svg class="icon weather-button" aria-hidden="true" width="25" height="18" viewBox="0 0 25 18"><path fill="#231F20" d="M12.9,16.6H3.6c-1.2,0-2.2-1-2.2-2.2c0-1.2,1-2.2,2.2-2.2l0.1,0c0.3,0,0.6-0.2,0.7-0.5c0.4-1.8,2-3,3.8-3 c1.2,0,2.3,0.6,3.1,1.5c-0.6,0.2-1.1,0.6-1.5,1.1c-0.1,0.1-0.2,0.3-0.2,0.5c0,0.2,0.1,0.4,0.2,0.5c0.1,0.1,0.3,0.2,0.5,0.2 c0.2,0,0.4-0.1,0.5-0.2c0.4-0.5,1-0.8,1.6-0.9c0.1,0,0.1,0,0.2,0c0.1,0,0.1,0,0.2,0c1.5,0,2.7,1.2,2.7,2.7 C15.6,15.4,14.4,16.6,12.9,16.6 M12.9,9.8c0,0-0.1,0-0.1,0c-1-1.6-2.7-2.6-4.6-2.6c-2.2,0-4.3,1.5-5,3.6C1.4,11,0,12.6,0,14.4 c0,2,1.6,3.6,3.6,3.6h9.3c2.2,0,4.1-1.8,4.1-4.1C17,11.6,15.1,9.8,12.9,9.8 M17,5c-1.5,0-2.8,0.6-3.8,1.8C13.1,6.9,13,7.1,13,7.3 c0,0.2,0.1,0.4,0.3,0.5c0.3,0.3,0.8,0.2,1-0.1C15,7,15.9,6.5,17,6.5c2,0,3.5,1.6,3.5,3.6c0,1-0.4,1.9-1,2.6 c-0.1,0.1-0.2,0.3-0.2,0.5c0,0.2,0.1,0.4,0.2,0.5c0.1,0.1,0.3,0.2,0.5,0.2c0.2,0,0.4-0.1,0.5-0.2c1-1,1.5-2.3,1.5-3.6 C22,7.3,19.7,5,17,5 M15.5,3C15.8,3,16,2.7,16,2.4V0.7C16,0.3,15.8,0,15.5,0C15.2,0,15,0.3,15,0.7v1.7C15,2.7,15.2,3,15.5,3 M24.3,9 h-1.7C22.3,9,22,9.2,22,9.5c0,0.3,0.3,0.5,0.7,0.5h1.7c0.4,0,0.7-0.2,0.7-0.5C25,9.2,24.7,9,24.3,9 M19.8,5c0.2,0,0.4-0.1,0.6-0.2 l1.4-1.4C21.9,3.2,22,3,22,2.8s-0.1-0.4-0.2-0.6c-0.3-0.3-0.8-0.3-1.1,0l-1.4,1.4C19.1,3.8,19,4,19,4.2s0.1,0.4,0.2,0.6 C19.4,4.9,19.6,5,19.8,5 M20.6,12.7c-0.1-0.1-0.3-0.2-0.6-0.2h0c-0.2,0-0.4,0.1-0.5,0.2c-0.1,0.1-0.2,0.3-0.2,0.6 c0,0.2,0.1,0.4,0.2,0.6l1.4,1.4c0.1,0.1,0.3,0.2,0.6,0.2c0.2,0,0.4-0.1,0.6-0.2c0.3-0.3,0.3-0.8,0-1.1L20.6,12.7z M10.7,4.8 C10.8,4.9,11,5,11.2,5c0.2,0,0.4-0.1,0.6-0.2c0.3-0.3,0.3-0.8,0-1.1l-1.4-1.4C10.2,2.1,10,2,9.8,2h0C9.6,2,9.4,2.1,9.2,2.2 C8.9,2.5,8.9,3,9.2,3.3L10.7,4.8z"></path></svg>
                </a>

                
                    
<form tabindex="-1" action="/search/" class="searchbox" id="site-search" role="search">
    
    <input type="text" name="q" placeholder="Search" aria-label="Search Fort Worth Star Telegram" tabindex="0">
    <button type="button" class="searchbox" tabindex="-1"><svg class="icon search-button" aria-hidden="true" width="18" height="18" viewBox="0 0 1792 1792"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z"></path></svg></button>
    <button type="submit" class="searchbox-go" aria-label="Search" tabindex="-1">
        &rarr;
    </button>
</form>

                
            </div>
        </div>

        
        
        <div class="middle-wrapper">
            <a href="/" class="middle" aria-label="Fort Worth Star Telegram">
                
                    <img src="/wps/build/images/star-telegram/logo.svg" alt="Fort Worth Star Telegram Logo" class="logo  short">
                
                
                    <h1 class="title-meta">Politician, ex-codebreaker Baroness Trumpington dies at 96 | Fort Worth Star-Telegram</h1>
                
            </a>
        </div>

        <div class="right paywall-links" role="menu">
            
            <div class="account-popup" role="menuitem">
                <div class="header">
                    <span class="user-name"></span>
                    <span class="close desktop mh-only-lg"></span>
                    <span class="close mh-hide-lg">&times;</span>
                </div>
                <div class="content"></div>
                <div class="footer"></div>
            </div>

            <button type="button" class="account-links mobile main" role="menu" aria-haspopup="true">
                <span class="initials"></span>
            </button>

            
                
    
    
    <script type="text/javascript">
        var userName = checkUserSubscribed('MPPUser');
        var signInOrAccountLink = '<a href="https://account.star-telegram.com/static/signin" class="mpp-usericon main mh-only-lg signed-out"><span>Sign In</span></a>';
        var subscribeLink = '<a href="https://account.star-telegram.com/static/subscribe" class="impact mh-only-lg"><span>Subscribe</span></a>';
        var label = "My Account";
        var signOutLink = '';

        if (getSubscribedFlag) {
            if(userName) {
              userName = JSON.parse(userName);
            }
            subscribeLink = '';
            signOutLink = '<a href="https://account.star-telegram.com/sign-out"><span>Sign Out</span></a>';

            if (userName && userName.firstName && userName.lastName) {
              label = userName.firstName + ' ' + userName.lastName;
            } else if (userName && userName.firstName) {
              label = userName.firstName;
            }
            signInOrAccountLink = '<a href="https://account.star-telegram.com/my-account" class="mpp-usericon account-links main mh-only-lg"><span>' + label + '</span></a>';
            var subscriptionLink = '<a href="https://account.star-telegram.com/my-account#subscriptions-tab" class="mpp-usericon account-links"><span>Subscriptions</span></a>';
        }
        if (1 === 1) {
            
            $(".right.paywall-links").prepend(signInOrAccountLink, " ", subscribeLink);
            signInOrAccountLink = signInOrAccountLink.replace("main mh-only-lg", "");
            var profileLink = signInOrAccountLink.replace(label, "Profile");
            $(".account-popup .content").prepend(profileLink, subscriptionLink);
            $(".account-popup .footer").prepend(signOutLink);

            if (getSubscribedFlag) {
              
                $(".account-popup .user-name").prepend(signInOrAccountLink);
                var f = userName.firstName.split('').shift(); 
                var l = userName.lastName.split('').shift();
                $(".account-links.mobile .initials").html(f+l);
            } else {
                var userIcon = '<svg class="icon subscribe-icon-button" width="16" height="22" viewBox="0 0 1792 1792"><path d="M1536 1399q0 109-62.5 187t-150.5 78h-854q-88 0-150.5-78t-62.5-187q0-85 8.5-160.5t31.5-152 58.5-131 94-89 134.5-34.5q131 128 313 128t313-128q76 0 134.5 34.5t94 89 58.5 131 31.5 152 8.5 160.5zm-256-887q0 159-112.5 271.5t-271.5 112.5-271.5-112.5-112.5-271.5 112.5-271.5 271.5-112.5 271.5 112.5 112.5 271.5z"></path></svg>';
                $(".account-links.mobile .initials").html(userIcon);
                subscribeLink = subscribeLink.replace("impact mh-only-lg", "");
                $(".account-popup .content").append(subscribeLink);
            }
        }
    </script>

            
        </div>
    </div>
    
</header>

<nav class="main-nav hidden" id="mainNav" role="menu" aria-hidden="true" tabindex="-1" >
<ul>
    
    <li class="action-item" role="menuitem">
        <button id="closenavigation" tabindex="0" >
            <span class="glyphicon glyphicon-close"></span>
            SECTIONS
        </button>
    </li>

    
    
        <li class="nav-search" role="menuitem">
            <button type="button" class="search-placeholder">
                <span class="glyphicon glyphicon-search"></span>
                <span>Search</span>
            </button>
            
<form tabindex="-1" action="/search/" class="searchbox" id="site-search" role="search">
    
    <input type="text" name="q" placeholder="Search" aria-label="Search Fort Worth Star Telegram" tabindex="0">
    <button type="button" class="searchbox" tabindex="-1"><svg class="icon search-button" aria-hidden="true" width="18" height="18" viewBox="0 0 1792 1792"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z"></path></svg></button>
    <button type="submit" class="searchbox-go" aria-label="Search" tabindex="-1">
        &rarr;
    </button>
</form>

        </li>
    

    
    <li class="nav-item">
        <a href="http://digital.olivesoftware.com/Olive/ODN/FortWorth/" class="eedition-link" role="menuitem" tabindex="0"><span class="transparent">E-edition</span></a>
    </li>
    

    
    

    <li class="nav-item nav-spacer" aria-hidden="true" tabindex="-1"></li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-1" >
    <button tabindex="-1" id="menubtn-1">Customer Service</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-1" role="menu" aria-labelledby="menubtn-1">
            <li class="subnav-item" role="none">
                
                
                <a href="/customer-service/#navlink=subnav" role="menuitem" tabindex="0">
                    Customer Service
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="https://www.star-telegram.com/mobile/#navlink=subnav" role="menuitem" tabindex="0">
                    Mobile &amp; Apps
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://x.email.star-telegram.com/ats/url.aspx?cr=663&amp;wu=12#navlink=subnav" role="menuitem" tabindex="0">
                    Newsletters
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-2" >
    
        <hr class="nav-divider" role="separator" aria-hidden="true" tabindex="-1">
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-3" >
    <button tabindex="-1" id="menubtn-3">News</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-3" role="menu" aria-labelledby="menubtn-3">
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/#navlink=subnav" role="menuitem" tabindex="0">
                    Local
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/fort-worth/#navlink=subnav" role="menuitem" tabindex="0">
                    Fort Worth
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/arlington/#navlink=subnav" role="menuitem" tabindex="0">
                    Arlington
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/northeast-tarrant/#navlink=subnav" role="menuitem" tabindex="0">
                    Northeast Tarrant
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/state/texas/#navlink=subnav" role="menuitem" tabindex="0">
                    Texas
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/crime#navlink=subnav" role="menuitem" tabindex="0">
                    Crime &amp; Courts
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/politics-government/#navlink=subnav" role="menuitem" tabindex="0">
                    Politics
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/politics-government/election/#navlink=subnav" role="menuitem" tabindex="0">
                    Elections
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/politics-government/texas-senate-race/#navlink=subnav" role="menuitem" tabindex="0">
                    Texas Senate Race
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/opn-columns-blogs/bud-kennedy/#navlink=subnav" role="menuitem" tabindex="0">
                    Bud Kennedy
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/special-reports/databases/#navlink=subnav" role="menuitem" tabindex="0">
                    Databases
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/nation-world/#navlink=subnav" role="menuitem" tabindex="0">
                    Nation and World
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-4" >
    <button tabindex="-1" id="menubtn-4">Sports</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-4" role="menu" aria-labelledby="menubtn-4">
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/nfl/dallas-cowboys/#navlink=subnav" role="menuitem" tabindex="0">
                    Cowboys
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/mlb/texas-rangers/#navlink=subnav" role="menuitem" tabindex="0">
                    Rangers
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/college/big-12/texas-christian-university/#navlink=subnav" role="menuitem" tabindex="0">
                    TCU
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/spt-columns-blogs/mac-engel/#navlink=subnav" role="menuitem" tabindex="0">
                    Mac Engel
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/college/#navlink=subnav" role="menuitem" tabindex="0">
                    Colleges
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/nba/dallas-mavericks/#navlink=subnav" role="menuitem" tabindex="0">
                    Mavericks
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/nascar-auto-racing/#navlink=subnav" role="menuitem" tabindex="0">
                    Motorsports
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/nhl/dallas-stars/#navlink=subnav" role="menuitem" tabindex="0">
                    Stars
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <span class="subcategory-title option-label" tabindex="-1">High School Sports</span>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/schedules/#navlink=subnav" role="menuitem" tabindex="0">
                    Scores &amp; Schedules
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/#navlink=subnav" role="menuitem" tabindex="0">
                    All Sports
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/prep-football/#navlink=subnav" role="menuitem" tabindex="0">
                    Football
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/prep-baseball/#navlink=subnav" role="menuitem" tabindex="0">
                    Baseball
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/prep-softball/#navlink=subnav" role="menuitem" tabindex="0">
                    Softball
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/prep-volleyball/#navlink=subnav" role="menuitem" tabindex="0">
                    Volleyball
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/boys-prep-basketball/#navlink=subnav" role="menuitem" tabindex="0">
                    Boys Basketball
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/sports/dfwvarsity/girls-prep-basketball/#navlink=subnav" role="menuitem" tabindex="0">
                    Girls Basketball
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-5" >
    <button tabindex="-1" id="menubtn-5">Opinion</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-5" role="menu" aria-labelledby="menubtn-5">
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/editorials/#navlink=subnav" role="menuitem" tabindex="0">
                    Editorials
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/letters-to-the-editor/#navlink=subnav" role="menuitem" tabindex="0">
                    Letters
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/letters-to-the-editor/submit-letter/#navlink=subnav" role="menuitem" tabindex="0">
                    Submit a letter
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/letters-to-the-editor/cheers-jeers/#navlink=subnav" role="menuitem" tabindex="0">
                    Cheers and Jeers
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/letters-to-the-editor/submit-letter/#navlink=subnav" role="menuitem" tabindex="0">
                    Submit a Cheer or Jeer
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/opn-columns-blogs/bud-kennedy/#navlink=subnav" role="menuitem" tabindex="0">
                    Bud Kennedy
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/opn-columns-blogs/michael-ryan/#navlink=subnav" role="menuitem" tabindex="0">
                    Michael Ryan
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/opn-columns-blogs/cynthia-m-allen/#navlink=subnav" role="menuitem" tabindex="0">
                    Cynthia M. Allen
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/opinion/opn-columns-blogs/other-voices/#navlink=subnav" role="menuitem" tabindex="0">
                    Other Voices
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-6" >
    <button tabindex="-1" id="menubtn-6">Business</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-6" role="menu" aria-labelledby="menubtn-6">
            <li class="subnav-item" role="none">
                
                
                <a href="/news/business/#navlink=subnav" role="menuitem" tabindex="0">
                    Business
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="https://www.star-telegram.com/news/business/growth/#navlink=subnav" role="menuitem" tabindex="0">
                    Growth
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-7" >
    <button tabindex="-1" id="menubtn-7">Entertainment</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-7" role="menu" aria-labelledby="menubtn-7">
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/restaurants/#navlink=subnav" role="menuitem" tabindex="0">
                    Restaurants
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/arts-culture/#navlink=subnav" role="menuitem" tabindex="0">
                    Arts &amp; Culture
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/movies/#navlink=subnav" role="menuitem" tabindex="0">
                    Movies
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/events/things-to-do/#navlink=subnav" role="menuitem" tabindex="0">
                    Things To Do
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/music/#navlink=subnav" role="menuitem" tabindex="0">
                    Music
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/nightlife/#navlink=subnav" role="menuitem" tabindex="0">
                    Nightlife
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/nightlife/party-pics/#navlink=subnav" role="menuitem" tabindex="0">
                    Party Pics
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/horoscopes/#navlink=subnav" role="menuitem" tabindex="0">
                    Horoscopes
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/comics/#navlink=subnav" role="menuitem" tabindex="0">
                    Comics
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/customer-service/contests-promotions/#navlink=subnav" role="menuitem" tabindex="0">
                    Contests
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://games.star-telegram.com/#navlink=subnav" role="menuitem" tabindex="0">
                    Puzzles and Games
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-8" >
    <button tabindex="-1" id="menubtn-8">Living</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-8" role="menu" aria-labelledby="menubtn-8">
            <li class="subnav-item" role="none">
                
                
                <a href="/living/food-drink/#navlink=subnav" role="menuitem" tabindex="0">
                    Food &amp; Drink
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/entertainment/arts-culture/#navlink=subnav" role="menuitem" tabindex="0">
                    Arts
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/living/health-fitness/#navlink=subnav" role="menuitem" tabindex="0">
                    Health &amp; Fitness
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/living/indulge#navlink=subnav" role="menuitem" tabindex="0">
                    Indulge
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/living/keller-magazine/#navlink=subnav" role="menuitem" tabindex="0">
                    The Keller Magazine
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/living/home-garden/neil-sperry/#navlink=subnav" role="menuitem" tabindex="0">
                    Neil Sperry
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/living/liv-columns-blogs/social-eyes/#navlink=subnav" role="menuitem" tabindex="0">
                    Social Eyes
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://www.uclick.com/client/ftw/da/#navlink=subnav" role="menuitem" tabindex="0">
                    Dear Abby
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="https://www.star-telegram.com/weddings/#navlink=subnav" role="menuitem" tabindex="0">
                    Weddings
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-9" >
    <button tabindex="-1" id="menubtn-9">Community News</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-9" role="menu" aria-labelledby="menubtn-9">
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/arlington-citizen-journal/#navlink=subnav" role="menuitem" tabindex="0">
                    Arlington Citizen-Journal
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/keller-citizen/#navlink=subnav" role="menuitem" tabindex="0">
                    Keller Citizen
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/northeast-tarrant/#navlink=subnav" role="menuitem" tabindex="0">
                    Star-Telegram Northeast
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/mansfield-news-mirror/#navlink=subnav" role="menuitem" tabindex="0">
                    Mansfield News-Mirror
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/news/local/community/weatherford-star-telegram/#navlink=subnav" role="menuitem" tabindex="0">
                    Weatherford Star-Telegram
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-10" >
    <button tabindex="-1" id="menubtn-10">La Estrella</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-10" role="menu" aria-labelledby="menubtn-10">
            <li class="subnav-item" role="none">
                
                
                <a href="/la-estrella/#navlink=subnav" role="menuitem" tabindex="0">
                    La Estrella
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/la-estrella/locales/#navlink=subnav" role="menuitem" tabindex="0">
                    Locales
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/la-estrella/noticias/#navlink=subnav" role="menuitem" tabindex="0">
                    Noticias
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/la-estrella/deportes/#navlink=subnav" role="menuitem" tabindex="0">
                    Deportes
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/la-estrella/entretenimiento/#navlink=subnav" role="menuitem" tabindex="0">
                    Entretenimiento
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/la-estrella/contactenos/#navlink=subnav" role="menuitem" tabindex="0">
                    Contáctenos
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://media.star-telegram.com/static/marketing/mediakit/pdf/2016laestrella.pdf#navlink=subnav" role="menuitem" tabindex="0">
                    Media Kit
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-11" >
    <button tabindex="-1" id="menubtn-11">Obituaries</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-11" role="menu" aria-labelledby="menubtn-11">
            <li class="subnav-item" role="none">
                
                
                <a href="http://www.legacy.com/obituaries/dfw/#navlink=subnav" role="menuitem" tabindex="0">
                    Today&#39;s Obituaries
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="https://www.star-telegram.com/news/local/obituaries/#navlink=subnav" role="menuitem" tabindex="0">
                    Obituaries in the News
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://www.legacy.com/obituaries/dfw/obituary-place-an-obituary.aspx#navlink=subnav" role="menuitem" tabindex="0">
                    Submit an Obituary
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-12" >
    
        <hr class="nav-divider" role="separator" aria-hidden="true" tabindex="-1">
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-13" >
    <button tabindex="-1" id="menubtn-13">Weddings</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-13" role="menu" aria-labelledby="menubtn-13">
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/#navlink=subnav" role="menuitem" tabindex="0">
                    All Weddings
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/announcements/#navlink=subnav" role="menuitem" tabindex="0">
                    Announcements
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/events/#navlink=subnav" role="menuitem" tabindex="0">
                    Bridal Show
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/contact-us/#navlink=subnav" role="menuitem" tabindex="0">
                    Contact Us
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/inspiration/#navlink=subnav" role="menuitem" tabindex="0">
                    Inspiration
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/news-and-advice/#navlink=subnav" role="menuitem" tabindex="0">
                    News &amp; Advice
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="/fort-worth-dallas-weddings/vendors/#navlink=subnav" role="menuitem" tabindex="0">
                    Vendors
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-14" >
    <button tabindex="-1" id="menubtn-14">Must Know</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-14" role="menu" aria-labelledby="menubtn-14">
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=94#navlink=subnav" role="menuitem" tabindex="0">
                    Hispanic Heritage
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=92#navlink=subnav" role="menuitem" tabindex="0">
                    Cancer Awareness
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=91#navlink=subnav" role="menuitem" tabindex="0">
                    Healthy Lifestyle
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=90#navlink=subnav" role="menuitem" tabindex="0">
                    Dining, Entertaining
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=89#navlink=subnav" role="menuitem" tabindex="0">
                    Breast Cancer Awareness
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=87#navlink=subnav" role="menuitem" tabindex="0">
                    Think Green
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=102#navlink=subnav" role="menuitem" tabindex="0">
                    Money Matters
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=98#navlink=subnav" role="menuitem" tabindex="0">
                    All About Pets
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=59#navlink=subnav" role="menuitem" tabindex="0">
                    Careers and Business
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=120#navlink=subnav" role="menuitem" tabindex="0">
                    Health and Wellness
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=119#navlink=subnav" role="menuitem" tabindex="0">
                    How To...
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=117#navlink=subnav" role="menuitem" tabindex="0">
                    Women Today
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=116#navlink=subnav" role="menuitem" tabindex="0">
                    Family and Parenting
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=83#navlink=subnav" role="menuitem" tabindex="0">
                    Easy Living Tips
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=114#navlink=subnav" role="menuitem" tabindex="0">
                    Lawn and Garden
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=99#navlink=subnav" role="menuitem" tabindex="0">
                    Giving Back
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=47#navlink=subnav" role="menuitem" tabindex="0">
                    Men Today
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=111#navlink=subnav" role="menuitem" tabindex="0">
                    On the Road 1
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://startelegram.qrsite.com/esection.php?sect=96#navlink=subnav" role="menuitem" tabindex="0">
                    On the Road 2
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-15" >
    
        <a href="http://www.legalnotice.org/pl/startelegram/landing1.aspx#navlink=subnav" tabindex="0" role="menuitem">Public Notices</a>
    </li>
    <li class="nav-item expandable" role="menu" tabindex="0"
        aria-haspopup="true" aria-controls="menu-16" >
    <button tabindex="-1" id="menubtn-16">Local Deals</button>
        <span class="glyphicon glyphicon-chevron-down icon" aria-hidden="true"></span>
        
        <ul class="nav-subnav" id="menu-16" role="menu" aria-labelledby="menubtn-16">
            <li class="subnav-item" role="none">
                
                
                <a href="http://findnsave.star-telegram.com/#navlink=subnav" role="menuitem" tabindex="0">
                    Shopping
                </a>
                
            </li>
            <li class="subnav-item" role="none">
                
                
                <a href="http://dfw.findnsave.com/PrintCoupons#navlink=subnav" role="menuitem" tabindex="0">
                    Grocery Coupons
                </a>
                
            </li>
            
        </ul>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-17" >
    
        <a href="/cars/#navlink=subnav" tabindex="0" role="menuitem">Cars</a>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-18" >
    
        <a href="https://jobs.star-telegram.com#navlink=subnav" tabindex="0" role="menuitem">Jobs</a>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-19" >
    
        <a href="http://www.startmoonlighting.com/mni/Fort-Worth-Star-Telegram/?utm_source=Fort-Worth-Star-Telegram&amp;utm_medium=navweblink&amp;utm_campaign=MNI#navlink=subnav" tabindex="0" role="menuitem">Moonlighting</a>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-20" >
    
        <a href="/homes/#navlink=subnav" tabindex="0" role="menuitem">Homes</a>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-21" >
    
        <a href="http://classifieds.star-telegram.com/#navlink=subnav" tabindex="0" role="menuitem">Classifieds</a>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-22" >
    
        <a href="/mobile/#navlink=subnav" tabindex="0" role="menuitem">Mobile &amp; Apps</a>
    </li>
    <li class="nav-item" role="menu" tabindex="-1"
        aria-haspopup="true" aria-controls="menu-23" >
    
        <hr class="nav-divider" role="separator" aria-hidden="true" tabindex="-1">
    </li>
</ul>
</nav>

    

        
    
        
            

























    






    


    


    



<div class="container ">
    <div id="leaderboard-ad" class="ad border-bottom">
        <!-- mobile-leaderboard class is integrated with sticky-leaderboard.js -->
        <div class="visible-xs mobile-leaderboard">
            <div class="ad-widget" id="mn-gpt-2" adtype="default" pkg="b" data-ad-policy="onPageLoad" audience="all" vl=0 atf="y" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="320x50" articleId="222234035"></div>
        </div>
        <div class="hidden-xs">
            <div class="ad-widget" id="mn-gpt-3" adtype="default" pkg="d" data-ad-policy="onPageLoad" audience="all" vl=0 atf="y" defaultsize="Large" Large="728x90" Medium="728x90" Small="728x90" Extra-Small="None" articleId="222234035"></div>
        </div>
    </div>
</div>
<section class="container story" role="main">
    <div class="row story-rail-wrapper">
        
        <div class="wide-rail">
            
            
                





    





    



    
    <div class="lead-item ">
        
            






    
        <div class="img-container picture ">
            <picture>
                <!--[if IE 9]><video style="display: none;"><![endif]-->
                <source srcset="//www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_1140/Britain_Obit_Codebreaking_Baroness_16899.jpg" media="(min-width: 992px)">
                <source srcset="//www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_960/Britain_Obit_Codebreaking_Baroness_16899.jpg" media="(min-width: 768px)">
                <source srcset="//www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_768/Britain_Obit_Codebreaking_Baroness_16899.jpg" media="(min-width: 601px)">
                <source srcset="//www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_640/Britain_Obit_Codebreaking_Baroness_16899.jpg" media="(min-width: 441px)">
                <source srcset="//www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_480/Britain_Obit_Codebreaking_Baroness_16899.jpg" media="(min-width: 320px)">
                <!--[if IE 9]></video><![endif]-->
                
                <img class="responsive-image"  srcset="//www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_1140/Britain_Obit_Codebreaking_Baroness_16899.jpg" alt="This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Baker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Baker says she died Monday in her sleep at the age of 96." title="This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Baker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Baker says she died Monday in her sleep at the age of 96." />
                
            </picture>
        
        </div>
    

            
                
                    <div class="caption">
                        
    
        <span class="caption-text">This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Baker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Baker says she died Monday in her sleep at the age of 96. </span>
    
    <span class="group-credit">
        
            <span class="photographer">PA via AP</span>
        
        
            <span class="credits">House of Commons</span>
        
    </span>

                    </div>
                
            
        
        
            <div class="lead-caption">
                
                    
                        
    
        <span class="caption-text">This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Baker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Baker says she died Monday in her sleep at the age of 96. </span>
    
    <span class="group-credit">
        
            <span class="photographer">PA via AP</span>
        
        
            <span class="credits">House of Commons</span>
        
    </span>

                    
                
            </div>
        
    </div>
    
        <script>
            jQuery(document).ready(function () {
                mi.leadAssets.init();
            });
        </script>
    


            
            
    
    
    

            <div id="story-header">
                <h2 class="heading section-main-heading link">
                    <a href="//www.star-telegram.com/news/nation-world/world/">World</a>
                </h2>

                <h3 class="title">Politician, ex-codebreaker Baroness Trumpington dies at 96</h3>
            </div>
            <div id="story-body-items"><div class="byline element-spacing-small"><span class="ng_byline_name">By JILL LAWLESS </span><span class="ng_byline_credit">Associated Press</span></div>
                    <div class="share-tools-wrapper">
                        









    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    
        
    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    

    











<ul class="share-icons">
    <li class="facebook">
        
            
                <a class="facebook-share" title="Share on Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://www.star-telegram.com/news/nation-world/world/article222234035.html" onclick="mi.articleShareTools.popupFunction(this.href, 5637);return false;"></a>
            
        
        <div class="glyphicon glyphicon-facebook"></div>
    </li>
    <li class="twitter">
        
            <a title="Share on Twitter" href="https://twitter.com/share?text=Politician,+ex-codebreaker+Baroness+Trumpington+dies+at+96&amp;url=https://www.star-telegram.com/news/nation-world/world/article222234035.html" onclick="mi.articleShareTools.popupFunction(this.href, 5638);return false;"></a>
        
        <div class="glyphicon glyphicon-twitter"></div>
    </li>
    
    <li class="email">
        
            <a title="Share by Email" href="mailto:?subject=Politician, ex-codebreaker Baroness Trumpington dies at 96&body=https://www.star-telegram.com/news/nation-world/world/article222234035.html" onclick="nextbee.credit_share_articles(5254);"></a>
        
        <div class="glyphicon glyphicon-envelope"></div>
    </li>
    <li class="more" onClick="return true">
        <ul class="share-options">
            
                <li class="linked-in"><a id="linkedInId" title="Share on LinkedIn" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.star-telegram.com/news/nation-world/world/article222234035.html&title=Politician, ex-codebreaker Baroness Trumpington dies at 96"><span class="glyphicon glyphicon-linkedin"></span>LinkedIn</a></li>
            
            
                <li class="google"><a title="Share on Google Plus" href="https://plus.google.com/share?url=https://www.star-telegram.com/news/nation-world/world/article222234035.html" onclick="mi.articleShareTools.popupFunction(this.href, 5296);return false;"><span class="glyphicon glyphicon-google-plus"></span>Google+</a></li>
            
            
                <li class="pinterest"><a id="pinterestId" title="Share on Pinterest" href="https://www.pinterest.com/pin/create/button/?url=https://www.star-telegram.com/news/nation-world/world/article222234035.html&description=Politician, ex-codebreaker Baroness Trumpington dies at 96&media=https://www.mcclatchy-wires.com/incoming/ltyjgj/picture222234030/alternates/LANDSCAPE_1140/Britain_Obit_Codebreaking_Baroness_16899.jpg"><span class="glyphicon glyphicon-pinterest-p"></span>Pinterest</a></li>
            
            <li class="reddit"><a title="Share on Reddit" href="https://www.reddit.com/submit?url=https://www.star-telegram.com/news/nation-world/world/article222234035.html"><span class="glyphicon glyphicon-reddit"></span>Reddit</a></li>
            <li class="print"><a title="Print" href="javascript:window.print();"><span class="glyphicon glyphicon-print"></span>Print</a></li>
            <li class="reprints"><a title="Reprints" href="https://www.mcclatchyreprints.com">Order Reprint of this Story</a></li>
        </ul>
        <div class="glyphicon glyphicon-share"></div>
    </li>
</ul>
<script type="text/javascript">
    $(document).ready(function () {
        mi.articleShareTools.init({
            nextLinkedin: '5324',
            nextPinterest: '5275'
        });
        mi.socialSharingScroll.init();
    });
</script>
                    </div>
                

                <div class="published-date-widget">
                    <p class="published-date">
                        <span id="publish_date">
                            November 27, 2018 07:35 AM
                        </span>
                    </p>
                    <p class="published-date">
                        
                            <span id="update_date">

                            </span>
                        
                    </p>
                </div>

                <div class="dateline-storybody">
                    
                        <span class="dateline">
                            LONDON
                        </span>
                    
                    <div id="story-target" class="clearfix">
                        <div id="content-body-" class="content-body">
                            
                            
                            
                            
                                
                                    <p>Socialite, codebreaker, British government minister and bon vivant Jean Barker — better known by her title, Baroness Trumpington — has died. She was 96.</p>
                                    
                                    
                                    
                                
                                    <p>Son Adam Barker said she died in her sleep on Monday. He tweeted that "she had a bloody good innings."</p>
                                    
                                    
                                    
                                
                                    <p>Jean Alys Campbell-Harris was born into a wealthy Anglo-American family on Oct. 23, 1922, and educated in England and France. When World War II broke out she worked on a farm as a "land girl" before serving in naval intelligence, translating messages from German submarines at the secret Bletchley Park codebreaking center.</p>
                                    
                                    
                                    
                                
                                    <p>After the war she worked for an organization in Paris helping to restore Europe's ravaged transport network before moving to New York, where she got a job in advertising and enjoyed the city's nightlife. She later said she arrived with just a few pounds in her pocket and subsisted on cocktail snacks until her first paycheck came through.</p>
                                    
                                        

    <div id="story-cta-widget" class="subscription-cta-widget cta-fullwidth hidden">
        <h2 class="widget-title">CYBER MONDAY SALE!</h2>
        <p class="widget-subhead">Only $20 for a full year of digital access! Hurry! Offer ends Monday!</p>
        <div class="btn btn-primary widget-button">
            <a href="https://account.star-telegram.com/subscribe/create?param=fHpHAUA=&amp;offer=NmEfaxcUb3lSCUJAfRIyf0I0fxdIckswHhpCG15QPgoUG0hQeHNDAEVHb29STx0HLisVS1BIbwUkbkBCDA0%2BbDM%2Bbz4%3D&amp;cid=CTA_20annual_offers_CyberMon">SUBSCRIBE NOW</a>
        </div>
    </div>

<script>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</script>


                                        
                                    
                                    
                                
                                    <p>Returning to England in the early 1950s, she married historian Alan Barker and entered Conservative politics, becoming a councilor and mayor of the city of Cambridge. She was appointed to the House of Lords in 1980 by Prime Minister Margaret Thatcher's government, taking the title Baroness Trumpington of Sandwich, and served as a minister and a whip during the 1980s and '90s.</p>
                                    
                                    
                                    
                                        
    
    
    <div class="ad visible-xs">
        <div class="ad-widget" id="mn-gpt-4" adtype="default" pkg="c" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="300x250" articleId="222234035"></div>
    </div>

                                        
                                    
                                
                                    <p>She was known for her sense of fun — dancing on tables and belting out "Chattanooga Choo Choo" at social functions well into old age — and for her forthright opinions. She received outraged letters from animal-lovers after suggesting that sheep in the Falkland Islands should be used to detect land mines.</p>
                                    
                                    
                                    
                                
                                    <p>"My point was that sheep could be put out of their misery and eaten, whereas men could not," Trumpington said.</p>
                                    
                                    
                                    
                                
                                    <p>She became a U.K. media star in 2011 after she made a rude hand signal in the House of Lords at a member who had referred to her age, a gesture caught on camera and endlessly replayed online.</p>
                                    
                                    
                                    
                                
                                    <p>She retired from the House of Lords last year on her 95th birthday.</p>
                                    
                                    
                                    
                                
                                    <p>Prime Minister Theresa May said Trumpington "was a formidable figure in British politics and her kindness and humor will be sorely missed."</p>
                                    
                                    
                                    
                                        
    
    
    <div class="ad visible-xs">
        <div class="ad-widget" id="mn-gpt-5" adtype="default" pkg="e" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="300x250" articleId="222234035"></div>
    </div>

                                        
                                    
                                
                                    <p>Former Prime Minister David Cameron tweeted that "she was one of a kind - they simply don't make politicians like that anymore. She will be sorely missed in Westminster but long remembered for her outstanding ability and great humour. RIP Trumpers."</p>
                                    
                                    
                                    
                                
                                    <p>International Development Secretary Penny Mordaunt wrote on Twitter: "Deepest sympathies to all who knew and loved this incredible woman. Socialite, mother, Bletchley Park code breaker, Baroness, Minister, trailblazer, heroine and an utter joy."</p>
                                    
                                    
                                    
                                
                            
                            
                        </div>
                        <div class="hidden">
                            <div class="ad-widget" id="mn-gpt-6" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Large" Large="336x280" Medium="336x280" Small="336x280" Extra-Small="336x280" articleId="222234035"></div>
                        </div>
                        
                            
                                <!-- Nothing is configured -->
                            
                        
                            
                                <!-- Nothing is configured -->
                            
                        
                            
                                
    
    
        





    
    <div class="ad visible-xs">
        <div class="ad-widget" id="mn-gpt-7" adtype="default" pkg="f" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Extra-Small" Large="None" Medium="None" Small="None" Extra-Small="300x250" articleId="222234035"></div>
    </div>

                            
                        

                        
                            
                            
                                
                                
                                
                                
                                    
                                
                                
                                    
                                
                                
                                


    


    
    
    <script type='text/template' id='inlinegallery-template-222234700'> 
    <div class="story-gallery spillover-gallery">
        <div id="slick-gallery-container-222234700" class="mi-slick-gallery-container clearfix" style="visibility: hidden;">
            <div class="preroll-container" data-uniqueID="222234700">
                
                
                <div class="slick-gallery">
                    
                        
                            <div class="gallery-item image">
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_160/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-160></span>
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_320/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-320></span>
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_480/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-480></span>
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_640/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-640></span>
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_768/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-768></span>
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_960/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-960></span>
                                <span data-src="//www.mcclatchy-wires.com/incoming/y8eqmc/picture222234700/alternates/FREE_1140/CORRECTION_Britain_Obit_Codebreaking_Baroness_16899.jpg" data-width-1140></span>
                                <img alt="This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Barker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Barker says she died Monday in her sleep at the age of 96." title="This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Barker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Barker says she died Monday in her sleep at the age of 96." />
                                <div class="caption">
                                    <span class="caption-text">This April 13, 2010 image made available on Tuesday, Nov. 27, 2018 shows British politician Jean Barker, better known by her title Baroness Trumpington, at the House of Commons, in London. Her son Adam Barker says she died Monday in her sleep at the age of 96. </span>
                                    <span class="group-credit">
                                        
                                            <span class="photographer">PA via AP</span>
                                        
                                        
                                            <span class="credits">House of Commons</span>
                                        
                                    </span>
                                </div>
                            </div>
                        
                    
                </div>
            </div>
            <div class="spillover-caption-carousel">
                <div class="current-caption  spillover-gallery"></div>
                
            </div>
            
        </div>
    </div>
     </script><div id='inlinegallery-target-222234700'></div><script> lazyLoadingModule("inlinegallery-template-222234700", "inlinegallery-target-222234700", "gallery",500,
        undefined, undefined, "undefined", 222234700 , 1 ); </script>


                            
                        
                    </div>
                </div>
                
                
                    

                

                
                
                    <div id="commenting-container" class="commenting-container element-spacing-large">
                        <h2 class="heading link">
    <a class="comments-toggle" href="javascript:void(0);">
        <span class="glyphicon glyphicon-comment-o"></span>&nbsp; Comments &nbsp;<span class="glyphicon glyphicon-chevron-down rotate"></span>
    </a>
</h2>

<!--Needs to be on the DOM on page load for IE. Needs to be visible to set the correct height of the comment component. I'm hiding it on document ready. Appending it later did not work-->
<div id="fb-comments" class="fb-comments in" data-href="https://www.star-telegram.com/news/nation-world/world/article222234035.html" data-width="100%" data-numposts="10"></div>

<script>
    jQuery(document).ready(function () {
        mi.commentingFaceboook.init();
    });
</script>

                    </div>
                
            </div>
            <div id="nativoArticlePage"></div>
        </div>
        


<div class="narrow-rail">
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-8" adtype="default" pkg="b" data-ad-policy="onPageLoad" audience="all" vl=0 atf="y" defaultsize="Large" Large="Flex Ad" Medium="Flex Ad" Small="300x250" Extra-Small="None" articleId="222234035"></div>
    </div>
    <div class="element-spacing-medium">
        <div id="video-widget" class="headline-list">
            <h2 class="heading link"><a href="/video/">Videos</a></h2>
            <div class="teaser">
                <div id="container-" class="container-">
                    
                        




<div class="wf-wps-side-bar mi-video-sidebar-widget">
    <div class="vjs-sidebar-player-wrap">
        

    

<div id="video-detail-222184130-1543326017027" class="media-wrap ">
    <div id="playerWrap-222184130-1543326017027" class="video-media vjs-wrapper">
        <video id="player-222184130-1543326017027"
               class="video-js vjs-16-9 mi-videojs brightcoveEnabled"
               data-url="https://www.star-telegram.com/news/nation-world/world/article222184130.html"
               data-title="Migrants vault over fence in Tijuana after tear gas launched"
               data-video-id="5971631159001"
               data-account="5615998025001"
               data-key="BCpkADawqM2rwsIfO8wUl9c9hB38MbOjlZotXHej_azhC4fpzDrgG_yDynchxYvWK82c6Tp7UrVLjnutTT3oczSjC6E62MdY8OIcX-N2LCEzzcGijSEWAcTMcilqgeTcauuTaCLWXjJ9Qwae"
               data-publication="star-telegram"
               data-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;description_url=https%3A%2F%2Fwww.star-telegram.com%2Fnews%2Fnation-world%2Fworld%2Farticle222184130.html&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;iu=%2F7675%2FFTW.site_star-telegram%2FNews%2FWorld&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;hl=en&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vid_t=Migrants%20vault%20over%20fence%20in%20Tijuana%20after%20tear%20gas%20launched&amp;vpa=0&amp;vpmute=0&amp;adtest=false&amp;ciu_szs=300x250&amp;cmsid=2475993&amp;vid=5971631159001&amp;cust_params=sect%3DWorld"
               data-asset-type="video"
               data-video-auto-play="false"
               data-video-type="sidebar"
               crossOrigin="anonymous"
               data-sport-article='false'
               data-is-new-video-design='false'>
               </video>
        <div class="vjs-share-wrapper">
    <div class="vjs-share">
        <button class="vjs-share-trigger">
            <span class="vjs-share-text">SHARE</span>
            <span class="vjs-share-icon glyphicon glyphicon-share"></span>
        </button>
    </div>
    <div class="vjs-overlay">
        <div class="vjs-overlay__sharing video-share-icons">
            <a href="" target="blank" class="vjs-overlay-sharing_item facebook-share glyphicon glyphicon-facebook"></a>
            <a href="" target="blank" class="vjs-overlay-sharing_item twitter-share glyphicon glyphicon-twitter"></a>
            <a href="mailto:?&subject=&body=" target="blank" class="vjs-overlay-sharing_item email-share glyphicon glyphicon-envelope"></a>
            <a href="#" class="vjs-overlay-sharing_item glyphicon glyphicon-code vjs-overlay-sharing__embed"></a>
            <form class="vjs-sharing__link">
                <textarea class="overlay-embed-share" cols="30"></textarea>
                <div class="vjs-input__wrapper">
                    <input type="text" class="mi-share-link" readonly value="">
                </div>
                <button type="button">COPY LINK</button>
            </form>
        </div>
    </div>
</div>
    </div>
</div>

        <h4 class="title video-title"><a href="//www.star-telegram.com/news/nation-world/world/article222184130.html">Migrants vault over fence in Tijuana after tear gas launched</a></h4>
    </div>
    <div class="vjs-sidebar-player-wrap">
        

    

<div id="video-detail-220668380-1543326017027" class="media-wrap ">
    <div id="playerWrap-220668380-1543326017027" class="video-media vjs-wrapper">
        <video id="player-220668380-1543326017027"
               class="video-js vjs-16-9 mi-videojs brightcoveEnabled"
               data-url="https://www.star-telegram.com/news/nation-world/world/article220668380.html"
               data-title="A day on the road with the migrant caravan"
               data-video-id="5853916361001"
               data-account="5615998025001"
               data-key="BCpkADawqM2rwsIfO8wUl9c9hB38MbOjlZotXHej_azhC4fpzDrgG_yDynchxYvWK82c6Tp7UrVLjnutTT3oczSjC6E62MdY8OIcX-N2LCEzzcGijSEWAcTMcilqgeTcauuTaCLWXjJ9Qwae"
               data-publication="star-telegram"
               data-ad-tag="https://pubads.g.doubleclick.net/gampad/ads?ad_type=video&amp;client=ca-video-pub-3446305859157241&amp;description_url=https%3A%2F%2Fwww.star-telegram.com%2Fnews%2Fnation-world%2Fworld%2Farticle220668380.html&amp;env=vp&amp;gdfp_req=1&amp;unviewed_position_start=1&amp;output=vast&amp;iu=%2F7675%2FFTW.site_star-telegram%2FNews%2FWorld&amp;sz=400x300&amp;url=[referrer_url]&amp;correlator=[timestamp]&amp;adsafe=high&amp;videoad_start_delay=0&amp;hl=en&amp;max_ad_duration=30000&amp;sdmax=120000&amp;vid_t=A%20day%20on%20the%20road%20with%20the%20migrant%20caravan&amp;vpa=0&amp;vpmute=0&amp;adtest=false&amp;ciu_szs=300x250&amp;cmsid=2475993&amp;vid=5853916361001&amp;cust_params=sect%3DWorld"
               data-asset-type="video"
               data-video-auto-play="false"
               data-video-type="sidebar"
               crossOrigin="anonymous"
               data-sport-article='false'
               data-is-new-video-design='false'>
               </video>
        <div class="vjs-share-wrapper">
    <div class="vjs-share">
        <button class="vjs-share-trigger">
            <span class="vjs-share-text">SHARE</span>
            <span class="vjs-share-icon glyphicon glyphicon-share"></span>
        </button>
    </div>
    <div class="vjs-overlay">
        <div class="vjs-overlay__sharing video-share-icons">
            <a href="" target="blank" class="vjs-overlay-sharing_item facebook-share glyphicon glyphicon-facebook"></a>
            <a href="" target="blank" class="vjs-overlay-sharing_item twitter-share glyphicon glyphicon-twitter"></a>
            <a href="mailto:?&subject=&body=" target="blank" class="vjs-overlay-sharing_item email-share glyphicon glyphicon-envelope"></a>
            <a href="#" class="vjs-overlay-sharing_item glyphicon glyphicon-code vjs-overlay-sharing__embed"></a>
            <form class="vjs-sharing__link">
                <textarea class="overlay-embed-share" cols="30"></textarea>
                <div class="vjs-input__wrapper">
                    <input type="text" class="mi-share-link" readonly value="">
                </div>
                <button type="button">COPY LINK</button>
            </form>
        </div>
    </div>
</div>
    </div>
</div>

        <h4 class="title video-title"><a href="//www.star-telegram.com/news/nation-world/world/article220668380.html">A day on the road with the migrant caravan</a></h4>
    </div>
</div>

                    
                </div>
                <div class="clearfix footer element_spacing_large">
                    <p class="readmore pull-left">
                        <a href="/video">
                            View More Video
                        </a>
                    </p>
                </div>
            </div>
        </div>
    </div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-9" adtype="default" pkg="c" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Large" Large="300x250" Medium="300x250" Small="300x250" Extra-Small="None" articleId="222234035"></div>
    </div>
    
        
            
    <div id="market-widget-1" class="element-spacing-medium">
        <!--   updated 5/5/17 and then reverted 5/8/17 kparker to change the file used for the featured_ads.json.  For a while, AP was sending invalid url in the xml.  But they fixed it so now this widget is back to the way it was.  
  update 6/26/18 to change script src to https protocol -->
<script src="https://media.star-telegram.com/static/scripts/classad_widget/MI_ClassAd_Widget.js"></script>
<script>
jQuery("document").ready(function (){
	mi.classadwidget = new mi.ClassAd_Widget({
		jsonURL : "https://media.star-telegram.com/static/scripts/classad_widget/featured_ads.json",
		targetElement : "#classified-featured-ads",
		setSize: 5,
		classad_url: "http://classifieds.star-telegram.com/detail/"
	});
});
</script>
<div id="classified-featured-ads" class="revenue-item headline-list element_spacing_large">
<h2>Local Spotlight</h2>
</div>
    </div>

        
    
    
    


<div class="element-spacing-medium">
    <section id="more-stories-widget" class="headline-list element_spacing_large">
        
            
                <h2 class="heading link">
                    <a href="/news/nation-world/world/">
                        World
                    </a>
                </h2>
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/news/nation-world/world/article222235335.html">
                                        Suspect in Dortmund bus attack convicted of attempted murder
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/news/nation-world/world/article222234910.html">
                                        Roadside bomb kills 3 US soldiers in eastern Afghanistan
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/news/nation-world/world/article222233290.html">
                                        The Latest: Polish president backs new sanctions on Russia
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/news/nation-world/world/article222233165.html">
                                        Kremlin warns of possible flare-up of hostilities in Ukraine
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                        <article class="media">
                            <div class="teaser">
                                <h2 class="title">
                                    <a href="//www.star-telegram.com/news/nation-world/world/article222235405.html">
                                        Israeli leader to visit Chad and restore relations
                                    </a>
                                </h2>
                            </div>
                        </article>
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                    
                
                <div class="clearfix">
                    <div class="more-stories-link wps-stories-link">
                        <a href="/news/nation-world/world/">
                            World
                        </a>
                    </div>
                </div>
            
        
            
        
    </section>
</div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-10" adtype="default" pkg="e" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Large" Large="Flex Ad" Medium="Flex Ad" Small="300x250" Extra-Small="None" articleId="222234035"></div>
    </div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-11" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="nonsub" vl=0 atf="n" defaultsize="Large" Large="300x250" Medium="300x250" Small="300x250" Extra-Small="None" oom="y"  articleId="222234035"></div>
    </div>
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-12" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="nonsub" vl=0 atf="n" defaultsize="Large" Large="300x250" Medium="300x250" Small="300x250" Extra-Small="None" oom="y"  articleId="222234035"></div>
    </div>
</div>

         <div id="story-body-items" class="suggested-content wide-rail">
            
            
                
                    


    <script type='text/template' id='zerg-template'> 
        <div id="vendor-stories-content">
            <h2 class='heading vendor-storiescontent-heading'>Suggested for you</h2>
        </div>
        <div class="vendor-storiescontent-main-container" id="zergnet-widget-53330"></div>
     </script><div id='zerg-target'></div><script> lazyLoadingModule("zerg-template", "zerg-target", "zerg",500,
        undefined, undefined, "53330", undefined , undefined ); </script>

                
            
        </div>
    </div>
</section>

<div class="container">
    <div class="ad hidden-xs">
        <div class="ad-widget" id="mn-gpt-13" adtype="default" pkg="None" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Large" Large="728x90" Medium="728x90" Small="728x90" Extra-Small="none" articleId="222234035"></div>
    </div>
</div>

    <img src="https://cdn.relaymedia.com/ping?url=%2F%2Fwww.star-telegram.com%2Fnews%2Fnation-world%2Fworld%2Farticle222234035.html" width="1" height="1">

<script type="text/javascript">
    jQuery(document).ready(function () {
        UD.updateDate.getDiffDate("1543325821", "MMMM DD, YYYY hh:mm A", "America/Chicago", "en", "-06:00");
    });
</script>

        
    

        
    
        


    

<div id="footer2018" class="wps-footer2018">
    <div class="content-footer">
        <div class="container">
            <div class="row">
                <div class="col-sm-10 col-md-6 connect-panel">
                    <div class="connect-pub">
                        <h6>Take Us With You</h6>
                        <p>Real-time updates and all local stories you want right in the palm of your hand.</p>
                        <div class="container">
                            
                            
                        </div>
                        <div class="social-footer2018">
                            
                                
                                    <div class="icon-wrap">
                                        <span><a href="http://www.facebook.com/startelegram" class="glyphicon  social-icon glyphicon-facebook-square"></a></span>
                                    </div>
                                
                            
                                
                                    <div class="icon-wrap">
                                        <span><a href="https://twitter.com/startelegram" class="glyphicon  social-icon glyphicon-twitter"></a></span>
                                    </div>
                                
                            
                                
                                    <div class="icon-wrap">
                                        <span><a href="http://www.youtube.com/user/startelegramvideo" class="glyphicon  social-icon glyphicon-youtube"></a></span>
                                    </div>
                                
                            
                                
                            
                        </div>
                    </div>
                </div>
                
                    <div class="col-sm-10 col-md-6 col-lg-2 panels">
                        <div id="accordion2018" class="info-footer2018">
                            <div class="panel-footer2018">
                                <div class="">
                                    <h6>Subscriptions</h6>
                                </div>
                                <div class="list-links-container">
                                    <ul class="list-links-footer2018">
                                        
                                            <li class="list-links-items"><a href="https://account.star-telegram.com/static/subscribe/#navlink=mi_footer">Start a Subscription</a></li>
                                        
                                            <li class="list-links-items"><a href="https://mcciservices.newscyclecloud.com/cmo_mcc-c-cmdb-cst-01/subscriber/web/signin.html?siteId=FTW">Customer Service</a></li>
                                        
                                            <li class="list-links-items"><a href="http://digital.olivesoftware.com/Olive/ODN/FortWorth/#navlink=mi_footer">eEdition</a></li>
                                        
                                            <li class="list-links-items"><a href="https://mcciservices.newscyclecloud.com/cmo_mcc-c-cmdb-cst-01/subscriber/web/signin.html?siteId=FTW">Vacation Hold</a></li>
                                        
                                            <li class="list-links-items"><a href="https://mcciservices.newscyclecloud.com/cmo_mcc-c-cmdb-cst-01/subscriber/web/signin.html?siteId=FTW">Pay Your Bill</a></li>
                                        
                                            <li class="list-links-items"><a href="/rewards">Rewards</a></li>
                                        
                                    </ul>
                                </div>
                            </div>
                        </div>
                    </div>
                
                    <div class="col-sm-10 col-md-6 col-lg-2 panels">
                        <div id="accordion2018" class="info-footer2018">
                            <div class="panel-footer2018">
                                <div class="">
                                    <h6>Learn More</h6>
                                </div>
                                <div class="list-links-container">
                                    <ul class="list-links-footer2018">
                                        
                                            <li class="list-links-items"><a href="https://www.star-telegram.com/customer-service/about-us/#navlink=mi_footer">About Us</a></li>
                                        
                                            <li class="list-links-items"><a href="https://www.star-telegram.com/customer-service/contact-us/#navlink=mi_footer">Contact Us</a></li>
                                        
                                            <li class="list-links-items"><a href="http://x.email.star-telegram.com/ats/url.aspx?cr=663&amp;wu=12#navlink=mi_footer">Newsletters</a></li>
                                        
                                            <li class="list-links-items"><a href="http://niestar-telegram.com/#navlink=mi_footer">News in Education</a></li>
                                        
                                    </ul>
                                </div>
                            </div>
                        </div>
                    </div>
                
                    <div class="col-sm-10 col-md-6 col-lg-2 panels">
                        <div id="accordion2018" class="info-footer2018">
                            <div class="panel-footer2018">
                                <div class="">
                                    <h6>Advertising</h6>
                                </div>
                                <div class="list-links-container">
                                    <ul class="list-links-footer2018">
                                        
                                            <li class="list-links-items"><a href="/advertise/#navlink=mi_footer#navlink=mi_footer">Information</a></li>
                                        
                                            <li class="list-links-items"><a href="http://fortworthstartelegram.adperfect.com/">Place a Classified</a></li>
                                        
                                            <li class="list-links-items"><a href="http://findnsave.star-telegram.com/#navlink=mi_footer">Shopping</a></li>
                                        
                                    </ul>
                                </div>
                            </div>
                        </div>
                    </div>
                
            </div>
        </div>
    </div>
    <div class="legal-footer2018">
        <div class="footer-menu">
            
                <div class="legal-panels">
                    <div class="legal-links-footer2018">
                        <a class="legal-links-item" href="/customer-service/copyright/#navlinks=mi_footer">Copyright</a>
                    </div>
                </div>
            
                <div class="legal-panels">
                    <div class="legal-links-footer2018">
                        <a class="legal-links-item" href="/customer-service/commenting-policy/#navlinks=mi_footer">Commenting Policy</a>
                    </div>
                </div>
            
                <div class="legal-panels">
                    <div class="legal-links-footer2018">
                        <a class="legal-links-item" href="/customer-service/privacy-policy/#navlink=mi_footer">Privacy Policy</a>
                    </div>
                </div>
            
                <div class="legal-panels">
                    <div class="legal-links-footer2018">
                        <a class="legal-links-item" href="/customer-service/terms-of-service/#navlink=mi_footer">Terms of Service</a>
                    </div>
                </div>
            
        </div>
    </div>
</div>


    <script type="text/javascript">
    jQuery(document).ready(function () {
        mi.footer.init();
    });
    </script>


  
    
        
            <div id="wallpaperWrapper" style="display:none;">
                <div class="ad-widget" id="mn-gpt-14" adtype="wallpaper" pkg="None" data-ad-policy="onPageLoad" audience="all" vl=0 atf="y" defaultsize="Large" Large="1600x600" Medium="None" Small="None" Extra-Small="None" articleId="222234035"><script type='text/javascript'>initWallpaperAd(['#mn-gpt-14'], 'section[role="main"]'); createWallpaperAd();</script></div>
            </div>
        

     

      
        
            
                <div id="floorboard" class="hidden-xs">
                    <div id="floorboard_outer">
                        <div id="floorTagWrapper" style="display:none;">
                            <div class="ad-widget" id="mn-gpt-15" adtype="floorboard" pkg="a" data-ad-policy="onPageLoad" audience="all" vl=0 atf="n" defaultsize="Large" Large="285x70" Medium="285x70" Small="285x70" Extra-Small="None" articleId="222234035"></div>
                        </div>
                    </div>
                </div>
            

        
      
    

    
        <script type="text/javascript">
        var optimeraEnabled = false;
        
            optimeraEnabled = true;
            var oDv = [];
            var oVa = {};
            mi_OptimeraTools.init('11');
            //Do not edit
            (function() {
                var optimeraHost = window.location.host;
                var optimeraPathName = window.location.pathname;
                var optimeraScript = document.createElement('script');
                optimeraScript.async = true;
                optimeraScript.type = 'text/javascript';
                rand = Math.random();
                optimeraScript.src="https://s3.amazonaws.com/elasticbeanstalk-us-east-1-397719490216/json/client/"+oDv[0]+"/"+optimeraHost+optimeraPathName+".js?t="+rand;
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(optimeraScript, node);
                var optimeraOpsScript = document.createElement('script');
                optimeraOpsScript.async = true;
                optimeraOpsScript.type = 'text/javascript';
                optimeraOpsScript.src='https://s3.amazonaws.com/elasticbeanstalk-us-east-1-397719490216/external_json/oPS.js';
                document.head.appendChild(optimeraOpsScript);
                var s = +new Date();
                while (+new Date() < s + 200) {/*Default 200ms Timeout*/};
            })();
            mi_Ads.env.create();
        
            mi_Ads.env.init();
        </script>
    
    <div id="mistatstag" style="display:none;">
        
            <script src="//media.star-telegram.com/mistats/products/escenic_s_code.js"></script>
            <script src="//media.star-telegram.com/mistats/products/escenic.js"></script>
            <script src="//media.star-telegram.com/mistats/finalizestats.js"></script>
        
    </div>


   














    
    
    
    
    
    
    
    

    
        
    

<script type="text/javascript">
    //<![CDATA[
    var clientDT = new Date().getTime();
    document.write('<img style="display:none;" src="https://ece-logger.nandomedia.com/analysis-logger/Logger?rt=1&ctxId=6071&contextPath=3187-6071&pubId=11&cat=&meta=read-wirestory&objId=222234035&type=article&title=Politician%2C+ex-codebreaker+Baroness+Trumpington+dies+at+96&url=%2F%2Fwww.star-telegram.com%2Fnews%2Fnation-world%2Fworld%2Farticle222234035.html&amp;clientDT=' + clientDT + '" alt="" width="1" height="1"/>');
    //]]>
</script>

<noscript>
    <div>
        <img src="https://ece-logger.nandomedia.com/analysis-logger/Logger?rt=1&ctxId=6071&contextPath=3187-6071&pubId=11&cat=&meta=read-wirestory&objId=222234035&type=article&title=Politician%2C+ex-codebreaker+Baroness+Trumpington+dies+at+96&url=%2F%2Fwww.star-telegram.com%2Fnews%2Fnation-world%2Fworld%2Farticle222234035.html" alt="one pixel graphics" width="1" height="1"/>
    </div>
</noscript>




    

        
    
        




<div class="overlay overlay-data">
    <div id="overlayParent">
        <div class="overlayHeading">
            <h3 class="title"></h3>
             
            <div class="arrow-box"></div>
        </div>
        


       
    </div>
    
    <div id="backToStory">
        <a class="backLink" href="//www.star-telegram.com/news/nation-world/world/article222234035.html">
            <span class="fa glyphicon-long-arrow-left"></span>
            <span class="back-label">Back to story</span>
        </a>
    </div>
</div>

    

        
        
    
<script type="text/javascript">
    var WFClientTypeDef = {
        "extraSmall": "(max-width: 767px)",
        "medium": "(min-width: 992px) and (max-width: 1199px)",
        "large": "(min-width: 1200px)",
        "small": "(min-width: 768px) and (max-width: 991px)"
    };
    var imageSizes = [80, 160, 200, 320, 400, 480, 560, 640, 720, 768, 960, 1080, 1140];
</script>
<script type="text/javascript" src="/wps/build/js/mi-footer-8ea046cb07.js"></script>

<script src="//imasdk.googleapis.com/js/sdkloader/ima3.js" type="text/javascript"></script>

    <script src="https://ovp.iris.tv/libs/adaptive/v2/iris.adaptive.js" type="text/javascript"></script>
    
        <script type="text/javascript" src="/wps/build/webpack/brightcoveVideo.bundle-1c36b9ef5c91d82b4d14.js"></script>
    



    <script type="text/javascript">
        /* <![CDATA[ */
        var google_conversion_id = 968074018;
        var google_custom_params = window.google_tag_params;
        var google_remarketing_only = true;
        /* ]]> */
    </script>
    <script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
    </script>
    <noscript>
        <div style="display:inline;">
            <img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/968074018/?value=0&guid=ON&script=0"/>
        </div>
    </noscript>




    <script type="text/javascript">
        mi.pageInfo.setConf("chartbeat.uid", 62447);
    </script>

<script src="/wps/source/scripts/libs/md5.min.js"></script>
<script type="text/javascript">
    var nextbee = {
        user_cookie: undefined,
        user_email: undefined,
        nextbee_host: "app.nextbee.com",
        nextbee_campaign: "3728",
        nextbee_client: "1703",
        API_AUTHORIZATION_KEY: 'DECGCFCFHEACGCDBIBGZ158469415068700193Y!n-868654787',
        ENCRYPTION_KEY: '0.9240762',

        credit_read_story: function() {
            this.post_to_nextbee("5439");
        },

        credit_watch_video: function() {
            this.post_to_nextbee("5248");
        },

        credit_share_articles: function(id, url) {
            this.post_to_nextbee(id, url);
        },

        initialize: function() {
            this.user_cookie = checkUserSubscribed('MPPUser');
            if (this.user_cookie) {
                var cookie_json = JSON.parse(this.user_cookie);
                if (cookie_json) {
                    this.user_email = cookie_json.NextBeeEmail;
                }
            }
            
                this.credit_read_story();
            
        },

        required_values_present: function (widget_id) {
            return this.user_cookie && this.user_email &&
                   this.nextbee_host && this.nextbee_client && this.nextbee_campaign &&
                   widget_id;
        },

        post_to_nextbee: function (widget_id, href) {
            if (this.required_values_present(widget_id)) {
                var nextbee_url = ['https://' + this.nextbee_host, 'nextbeeapis',
                    this.nextbee_client, this.nextbee_campaign, 'Event'].join('/') +
                    '?email=' + encodeURIComponent(this.user_email) +
                    '&widget_config_id=' + widget_id;
                var timestamp_key = Math.floor(Date.now()).toString();
                var api_call_signature = md5(this.API_AUTHORIZATION_KEY +
                    this.ENCRYPTION_KEY + timestamp_key);

                console.log("NextBee URL: " + nextbee_url +
                    "\nAuth. Key: " + this.API_AUTHORIZATION_KEY +
                    "\nEnc. Key:  " + this.ENCRYPTION_KEY +
                    "\nTimestamp: " + timestamp_key +
                    "\nSignature: " + api_call_signature);

                $.ajax( { url: nextbee_url, type: 'post', headers: {
                    'ts-key': timestamp_key,
                    'api-call-signature': api_call_signature,
                    'cache-control': 'no-cache',
                    'content-type': 'application/json',
                    },
                    complete: function(data) {
                        if(href)
                        {
                            window.location.href = href;
                        }
                        console.log("NextBee API response: " + data.responseText);
                    }
                } );
            }
        }
    };

    $(function(){
        nextbee.initialize();
    });
</script>



<!-- Start Lotame Tag -->
    <script src="//tags.crwdcntrl.net/c/7450/cc.js?ns=_cc7450" id="LOTCC_7450"></script>
    <script>_cc7450.bcp();</script>
<!-- End Lotame Tag -->



    

        
    

    </body>
</html>
